diff mbox series

[bug#36182] add freeorion

Message ID 20190612102219.6cc0d25f@gmail.com
State Accepted
Headers show
Series [bug#36182] add freeorion | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Jesse Gibbons June 12, 2019, 4:22 p.m. UTC
Patch is attached.
-Jesse

Comments

Nicolas Goaziou June 12, 2019, 7:48 p.m. UTC | #1
Hello,

Jesse Gibbons <jgibbons2357@gmail.com> writes:

> Patch is attached. -Jesse

Thank you! Some comments follow.

> From cca52f508e84ac34e60a3c5167554d7ad2ad6564 Mon Sep 17 00:00:00 2001
> From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
> Date: Wed, 12 Jun 2019 10:07:32 -0600
> Subject: [PATCH] add freeorion

The commit message is incomplete. It should also include

    * gnu/packages/games.scm (freeorion): New variable.

If you use Emacs, there is a template to automatically fill this.

> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/freeorion/freeorion.git")
> +             (commit "470d0711537804df3c2ca25532f674ab4bec58af")))

Why do you need to use the latest commit instead of the latest stable
release? Unless there is a good reason, Guix prefers using stable
releases:

    (commit version)

> +       (sha256
> +        (base32
> +         "1wsw632l1cj17px6i88nqjzs0dngp5rsr67n6qkkjlfjfxi69j0f"))))
> +    (arguments
> +     '(#:tests? #f))

You should include a comment explaining why tests are removed. It could
be, for example,

    '(#:tests? #f))   ;no test 

> +    (home-page
> +     "https://www.freeorion.org/index.php/Main_Page")

I think "https://www.freeorion.org" is enough, since it points to the
page above.

> +    (description
> +     "FreeOrion is a free, open source, turn-based space empire and galactic
> +conquest (4X) computer game being designed and built by the FreeOrion project.
> +FreeOrion is inspired by the tradition of the Master of Orion games, but is not
> +a clone or remake of that series or any other game.")

It may be useful to explain what the "4X" means, or do not include it at
all. Note that in the wiki, "4X" is a link, so you can get further
information.

> +    (license (list license:gpl2 license:cc-by-sa3.0))))

Could you explain, in a comment, why there are two licenses? I assume
the former is the project, and the latter is for assets.

Would you mind sending an updated patch?

Regards,
diff mbox series

Patch

From cca52f508e84ac34e60a3c5167554d7ad2ad6564 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Wed, 12 Jun 2019 10:07:32 -0600
Subject: [PATCH] add freeorion

---
 gnu/packages/games.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7a433a0bfd..1f7ace8888 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7385,3 +7385,42 @@  full of enemies that can hurt it, obstacles and food to be eaten.  The goal of
 the game is to stay alive and collect prizes.  The robot program conveniently
 may be written in a plain text file in the Scheme programming language.")
     (license license:gpl3+)))
+
+(define-public freeorion
+  (package
+    (name "freeorion")
+    (version "0.4.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/freeorion/freeorion.git")
+             (commit "470d0711537804df3c2ca25532f674ab4bec58af")))
+       (sha256
+        (base32
+         "1wsw632l1cj17px6i88nqjzs0dngp5rsr67n6qkkjlfjfxi69j0f"))))
+    (arguments
+     '(#:tests? #f))
+    (build-system cmake-build-system)
+    (inputs `(("boost" ,boost)
+              ("boost_signals" ,boost-signals2)
+              ("freetype2" ,freetype)
+              ("python2" ,python-2.7)
+              ("openal" ,openal)
+              ("libogg" ,libogg)
+              ("libvorbis" ,libvorbis)
+              ("zlib" ,zlib)
+              ("libpng" ,libpng)
+              ("sdl2" ,sdl2)
+              ("glu" ,glu)
+              ("glew" ,glew)))
+    (home-page
+     "https://www.freeorion.org/index.php/Main_Page")
+    (synopsis
+     "Turn-based space empire and galactic conquest computer game")
+    (description
+     "FreeOrion is a free, open source, turn-based space empire and galactic
+conquest (4X) computer game being designed and built by the FreeOrion project.
+FreeOrion is inspired by the tradition of the Master of Orion games, but is not
+a clone or remake of that series or any other game.")
+    (license (list license:gpl2 license:cc-by-sa3.0))))
-- 
2.22.0