diff mbox series

[bug#36050] gnu: Add emacs-xterm-color

Message ID 20190607034000.21850-1-jonathan@terracrypt.net
State Accepted
Headers show
Series [bug#36050] gnu: Add emacs-xterm-color | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Jonathan Frederickson June 7, 2019, 3:40 a.m. UTC
* gnu/packages/emacs-xyz.scm: (emacs-xterm-color) new variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


Here's a revised version - I saw there were a few different
conventions for packages with git sources, but I figured using both a
numeric version for the version I intended and a git hash for
stability would be desirable.

Comments

Ludovic Courtès June 7, 2019, 7:30 a.m. UTC | #1
Hi,

Jonathan Frederickson <jonathan@terracrypt.net> skribis:

> * gnu/packages/emacs-xyz.scm: (emacs-xterm-color) new variable.

Applied, thanks!

I followed up with a commit to address ‘guix lint’ warnings.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9199b45e40..3224883969 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15620,4 +15620,23 @@  verb commands which would are normally destructive (such as deletion) are
 provided.  Those alternative commands are and bound by default to their
 corresponding Evil keys.")
       (license license:expat))))
+
+(define-public emacs-xterm-color
+  (let ((commit "a452ab38a7cfae97078062ff8885b5d74fd1e5a6")
+        (version "1.8")
+        (revision "1"))
+    (package
+      (name "emacs-xterm-color")
+      (version (git-version version revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/atomontage/xterm-color.git")
+                      (commit commit)))
+                (sha256
+                 (base32 "02kpajb993yshhjhsizpfcbrcndyzkf4dqfipifhxxng50dhp95i"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/atomontage/xterm-color")
+      (synopsis "ANSI & xterm-256 color text property translator for Emacs")
+      (description "@code{xterm-color.el} is an ANSI control sequence to text-property translator.")
+      (license license:bsd-2))))
--