diff mbox series

[bug#36055] gnu: emacs-google-translate: Update to 0.11.17.

Message ID 20190602132009.2753-1-mthl@gnu.org
State Accepted
Headers show
Series [bug#36055] gnu: emacs-google-translate: Update to 0.11.17. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Mathieu Lirzin June 2, 2019, 1:20 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-google-translate): Update to 0.11.17.
[source]: Use 'git-fetch' method instead of 'url-fetch'.
---
 gnu/packages/emacs-xyz.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)

Comments

Ludovic Courtès June 2, 2019, 8:20 p.m. UTC | #1
Hi Mathieu,

Mathieu Lirzin <mthl@gnu.org> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-google-translate): Update to 0.11.17.
> [source]: Use 'git-fetch' method instead of 'url-fetch'.

Applied, thank you! :-)

Ludo’.
Mathieu Lirzin June 2, 2019, 9 p.m. UTC | #2
Hello Ludo,

Ludovic Courtès <ludo@gnu.org> writes:

> Mathieu Lirzin <mthl@gnu.org> skribis:
>
>> * gnu/packages/emacs-xyz.scm (emacs-google-translate): Update to 0.11.17.
>> [source]: Use 'git-fetch' method instead of 'url-fetch'.
>
> Applied, thank you! :-)

I hope you are doing well, thanks for your prompt answer. :-)

For the record I did the update because after noticing a bug in
‘emacs-google-translate’ 0.11.16, unfortunately this bug is still
present in 0.11.17. There is an opened issue on Github [1].

[1] https://github.com/atykhonov/google-translate/issues/52
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c2d515ed95..c2b3bfddcb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33,7 +33,7 @@ 
 ;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
 ;;; Copyright © 2017, 2018, 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2018 Sohom Bhattacharjee <soham.bhattacharjee15@gmail.com>
-;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
+;;; Copyright © 2018, 2019 Mathieu Lirzin <mthl@gnu.org>
 ;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018, 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
 ;;; Copyright © 2018, 2019 Jack Hill <jackhill@jackhill.us>
@@ -12522,16 +12522,17 @@  the GIF result.")
 (define-public emacs-google-translate
   (package
     (name "emacs-google-translate")
-    (version "0.11.16")
+    (version "0.11.17")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/atykhonov/google-translate/"
-                           "archive/v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/atykhonov/google-translate/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "01n9spj1d0gjfj39x526rl3m9c28wnx9afipmf5s8y77cx3mfwhl"))))
+         "05ljjw7kbnszygw3w085kv57swfiiqxri2b5xvsf5dw3pc3g7j3c"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/atykhonov/google-translate")
     (synopsis "Emacs interface to Google Translate")