diff mbox series

[bug#36050] gnu: Add emacs-xterm-color

Message ID 20190602025956.1666-1-jonathan@terracrypt.net
State Accepted
Headers show
Series [bug#36050] gnu: Add emacs-xterm-color | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Jonathan Frederickson June 2, 2019, 2:59 a.m. UTC
* gnu/packages/emacs-xyz.scm: (emacs-xterm-color) new variable.
---
 gnu/packages/emacs-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Ludovic Courtès June 5, 2019, 3:27 p.m. UTC | #1
Hi Jonathan,

Jonathan Frederickson <jonathan@terracrypt.net> skribis:

> * gnu/packages/emacs-xyz.scm: (emacs-xterm-color) new variable.

[...]

> +              (uri (string-append
> +                    "https://melpa.org/packages/xterm-color-"
> +                    version
> +                    ".el"))

melpa.org URLs are not stable: files get modified in place.  For that
reason, we usually refer directly to upstream VCS repositories.

Could you modify the patch accordingly?

> +    (synopsis "ANSI & xterm-256 color text property translator for Emacs")
> +    (description "@code{xterm-color.el} is an ANSI control sequence to text-property translator")

Please add a period at the end of the sentence.  :-)

Thank you,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9199b45e40..70dd9e599b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15620,3 +15620,21 @@  verb commands which would are normally destructive (such as deletion) are
 provided.  Those alternative commands are and bound by default to their
 corresponding Evil keys.")
       (license license:expat))))
+
+(define-public emacs-xterm-color
+  (package
+    (name "emacs-xterm-color")
+    (version "20190519.1243")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://melpa.org/packages/xterm-color-"
+                    version
+                    ".el"))
+              (sha256
+               (base32 "0cdl8cpqv3x23y4vpfib4kjncy9xslvka04gpszdnasf7av5g8g7"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/atomontage/xterm-color")
+    (synopsis "ANSI & xterm-256 color text property translator for Emacs")
+    (description "@code{xterm-color.el} is an ANSI control sequence to text-property translator")
+    (license license:bsd-2)))