diff mbox series

[bug#35999] gnu: add gthumb

Message ID 20190530071011.9435-1-atai@atai.org
State Accepted
Headers show
Series [bug#35999] gnu: add gthumb | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Andy Tai May 30, 2019, 7:10 a.m. UTC
From: Andy Tai <atai@atai.org>

 * gnu/packages/gnome.scm (gthumb): Add at 3.8.0
---
 gnu/packages/gnome.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Ricardo Wurmus May 30, 2019, 7:37 a.m. UTC | #1
Hi Andy,

>  * gnu/packages/gnome.scm (gthumb): Add at 3.8.0

thanks for the patch.

(Note that the commit message should be “Add variable.”)


> +    (arguments
> +     `(#:validate-runpath? #f))

It’s not a good idea to disable RUNPATH validation, because it usually
shows you that something might be wrong.  In this package the problem is
that the RUNPATH does not include the lib/gthumb/extensions
directory.

I’m still fighting with a handful of binaries that don’t seem to get the
right RUNPATH, but once that’s done I’ll push the updated patch to the
master branch.
Ricardo Wurmus May 30, 2019, 9:51 a.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> writes:

> Hi Andy,
>
>>  * gnu/packages/gnome.scm (gthumb): Add at 3.8.0
>
> thanks for the patch.
>
> (Note that the commit message should be “Add variable.”)
>
>
>> +    (arguments
>> +     `(#:validate-runpath? #f))
>
> It’s not a good idea to disable RUNPATH validation, because it usually
> shows you that something might be wrong.  In this package the problem is
> that the RUNPATH does not include the lib/gthumb/extensions
> directory.
>
> I’m still fighting with a handful of binaries that don’t seem to get the
> right RUNPATH, but once that’s done I’ll push the updated patch to the
> master branch.

Pushed to the master branch with commit 169d63f533.
I fixed the RUNPATH problems and made sure the application doesn’t crash
with a GLib-GIO-ERROR error by adding #:glib-or-gtk? #t.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 14e63280ed..371d8b2509 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7974,3 +7974,43 @@  functionality.")
     (license (list license:lgpl2.1 license:lgpl3 ; either one of these
                    license:openldap2.8 ; addressbook/gui/component/openldap-extract.h
                    license:lgpl2.1+))))  ; smime/lib/*
+
+
+(define-public gthumb
+  (package
+    (name "gthumb")
+    (version "3.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/gthumb/"
+                                  (version-major+minor version) "/"
+                                  "gthumb-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1l2s1facq1r6yvqjqc34aqfzlvb3nhkhn79xisxbbdlgrrxdq52f"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:validate-runpath? #f))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("glib:bin" ,glib "bin")         ; For glib-compile-resources
+       ("gtk+:bin" ,gtk+ "bin")         ; For gtk-update-icon-cache
+       ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+       ("intltool" ,intltool)
+       ("itstool" ,itstool)))
+    (inputs
+     `(("exiv2" ,exiv2)
+       ("gtk" ,gtk+)
+       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+       ("gstreamer" ,gstreamer)
+       ("clutter" ,clutter)
+       ("clutter-gst" ,clutter-gst)
+       ("clutter-gtk" ,clutter-gtk)
+       ("libjpeg" ,libjpeg)
+       ("libtiff" ,libtiff)
+       ("libraw" ,libraw)))
+    (synopsis "GNOME image viewer and browser")
+    (description "GThumb is an image viewer, browser, organizer, editor and
+advanced image management tool")
+    (home-page "https://wiki.gnome.org/Apps/Gthumb")
+    (license license:gpl2+)))