@@ -36,6 +36,7 @@
;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2019 Li-Cheng (Andy) Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -162,6 +163,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -7974,3 +7976,40 @@ functionality.")
(license (list license:lgpl2.1 license:lgpl3 ; either one of these
license:openldap2.8 ; addressbook/gui/component/openldap-extract.h
license:lgpl2.1+)))) ; smime/lib/*
+
+(define-public terminator
+ (package
+ (name "terminator")
+ (version "1.91")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/" name "/"
+ "gtk3/" version "/" "+download/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sdyqwydmdnh7j6mn74vrywz35m416kqsbxbrqcnv5ak08y6xxwm"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("glib" ,glib "bin")
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("gtk+" ,gtk+)
+ ("gobject-introspection" ,gobject-introspection)
+ ("pango" ,pango)
+ ("python" ,python-2)
+ ("python2-pycairo" ,python2-pycairo)
+ ("python2-pygobject" ,python2-pygobject)
+ ("python2-psutil" ,python2-psutil)
+ ("vte" ,vte)))
+ (arguments
+ `(#:python ,python-2))
+ (home-page "https://gnometerminator.blogspot.com/")
+ (synopsis "Store and run multiple GNOME terminals in one window")
+ (description
+ "Terminator allows running multiple GNOME terminals in a grid and
+tabs and supports for drag and drop re-ordering of terminals")
+ (license license:gpl2)))
From: Andy Tai <atai@atai.org> * gnu/packages/gnome.scm (terminator): Add at 1.91 --- gnu/packages/gnome.scm | 39 +++++++++++++++++++++++++++++++++++++++ 1 file changed, 39 insertions(+)