diff mbox series

[bug#35990,9/9] gnu: Add sbcl-dbus.

Message ID 20190529132956.7454-9-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#35985,1/9] gnu: Add idna. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Pierre Neidhardt May 29, 2019, 1:29 p.m. UTC
* gnu/packages/lisp.scm (sbcl-dbus): New variable.
---
 gnu/packages/lisp.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 31d2e8d550..2aa73aaa38 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5505,3 +5505,31 @@  and @code{kqueue(2)}), a pathname library and file-system utilities.")
                (("\\(:file \"sockets\" :depends-on \\(\"pkgdcl\" \"defsuites\"\\)\\)")
                 "")))))))
     (synopsis "Common Lisp I/O library")))
+
+(define-public sbcl-dbus
+  (let ((commit "24b452df3a45ca5dc95015500f34baad175c981a")
+        (revision "1"))
+    (package
+      (name "sbcl-dbus")
+      (build-system asdf-build-system/sbcl)
+      (version (git-version "20190408" revision commit))
+      (home-page "https://github.com/death/dbus")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0fw2q866yddbf23nk9pxphm9gsasx35vjyss82xzvndnjmzlqfl5"))))
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+         ("trivial-garbage" ,sbcl-trivial-garbage)
+         ("babel" ,sbcl-babel)
+         ("sbcl-iolib" ,sbcl-iolib)))   ; TODO: Fails because iolib-multiplex cannot be found.
+      (synopsis "D-BUS client library for Common Lisp")
+      (description "This is a Common Lisp library that allows to publish D-Bus
+objects as well as send and notify other objects connected to a bus.")
+      (license license:bsd-2))))