diff mbox series

[bug#34971,v2] gnu: Add mako.

Message ID 20190529030924.19859-1-meiyo@riseup.net
State Accepted
Headers show
Series [bug#34971,v2] gnu: Add mako. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Meiyo Peng May 29, 2019, 3:09 a.m. UTC
* gnu/packages/notification.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk                  |  1 +
 gnu/packages/notification.scm | 59 +++++++++++++++++++++++++++++++++++
 2 files changed, 60 insertions(+)
 create mode 100644 gnu/packages/notification.scm

Comments

Marius Bakke Jan. 30, 2020, 11:41 a.m. UTC | #1
Meiyo Peng <meiyo@riseup.net> writes:

> * gnu/packages/notification.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

Looks like Gábor committed a version of this in
46dc940c9af3d8b48966d16e52273ba88e92f946.

Sorry for the duplicate work!
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 3a199f82f8..fb02c8aa8c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -342,6 +342,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/nim.scm  			\
   %D%/packages/ninja.scm			\
   %D%/packages/node.scm				\
+  %D%/packages/notification.scm			\
   %D%/packages/noweb.scm			\
   %D%/packages/nss.scm				\
   %D%/packages/ntp.scm				\
diff --git a/gnu/packages/notification.scm b/gnu/packages/notification.scm
new file mode 100644
index 0000000000..0e7abb8693
--- /dev/null
+++ b/gnu/packages/notification.scm
@@ -0,0 +1,59 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages notification)
+  #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages man)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (guix build-system meson)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages))
+
+(define-public mako
+  (let ((commit "ca8e763f06756136c534b1bbd2e5b536be6b1995")
+        (revision "1"))
+    (package
+      (name "mako")
+      (version (string-append "1.3-" revision "."
+                              (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/emersion/mako.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1w16n58xj4ncaqjlwczq7i8kpxi05hjp2dqkqhajd9dzk0bd77qy"))))
+      (build-system meson-build-system)
+      (inputs
+       `(("cairo" ,cairo)
+         ("elogind" ,elogind)
+         ("pango" ,pango)
+         ("wayland" ,wayland)
+         ("wayland-protocols" ,wayland-protocols)))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)
+         ("scdoc" ,scdoc)))
+      (home-page "https://github.com/emersion/mako")
+      (synopsis "Lightweight Wayland notification daemon")
+      (description "@code{mako} is a lightweight notification daemon for
+Wayland.")
+      (license license:expat))))