diff mbox series

[bug#35970] gnu: Add qview.

Message ID 20190528225105.10540-1-mail@nicolasgoaziou.fr
State Accepted
Headers show
Series [bug#35970] gnu: Add qview. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Nicolas Goaziou May 28, 2019, 10:51 p.m. UTC
* gnu/packages/image-viewers.scm (qview): New variable.
---
 gnu/packages/image-viewers.scm | 48 ++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)

Comments

Ludovic Courtès June 1, 2019, 1:06 p.m. UTC | #1
Salut,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

> * gnu/packages/image-viewers.scm (qview): New variable.

[...]

> +    (synopsis "Practical and minimal image viewer")
                  ^~~~~~~~~

Did you mean “convenient”?  :-)
(It surely is practical too, but the same could be said of all the image
viewers we have.)

Otherwise LGTM!

Ludo’.
Nicolas Goaziou June 1, 2019, 8:52 p.m. UTC | #2
Hello,

Thank you for the review.

Ludovic Courtès <ludo@gnu.org> writes:

> Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:
>
>> * gnu/packages/image-viewers.scm (qview): New variable.
>
> [...]
>
>> +    (synopsis "Practical and minimal image viewer")
>                   ^~~~~~~~~
>
> Did you mean “convenient”?  :-)
> (It surely is practical too, but the same could be said of all the image
> viewers we have.)

OK. Bikeshedding time :)

I used the words from the developers themselves
<https://github.com/jurplel/qView>, so I didn't mean anything in
particular. 

However, AFAIU, there is a difference between practical and convenient:
the latter suggests some ease of use that the former doesn't. For
example, the `find' utility is practical, but not what I would call
convenient.

Now, I don't have a strong opinion about it. I just wanted to be
faithful to the developers' words.

Bikeshedding time's over.

So, "Practical" or "convenient", or something different, like:

  "Fully-featured yet unobtrusive image viewer"


Regards,
Ludovic Courtès June 1, 2019, 9:53 p.m. UTC | #3
Hi!

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

> However, AFAIU, there is a difference between practical and convenient:
> the latter suggests some ease of use that the former doesn't. For
> example, the `find' utility is practical, but not what I would call
> convenient.

Yes, that’s what I meant.

I commented because I was quite sure “convenient” was meant and because
“practical” is a false friend in French, but it’s no big deal.

So please push with your preferred wording!  :-)

Ludo’.
Nicolas Goaziou June 5, 2019, 9:45 p.m. UTC | #4
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

> I commented because I was quite sure “convenient” was meant and because
> “practical” is a false friend in French, but it’s no big deal.
>
> So please push with your preferred wording!  :-)

Fair enough. I used "convenient" and pushed the commit.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 82b44a4900..8dee417cdb 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2017 nee <nee-git@hidamari.blue>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -429,3 +430,50 @@  imaging.  It supports several HDR and LDR image formats, and it can:
 a comic and manga reader.  It supports a variety of container formats
 including CBZ, CB7, CBT, LHA.")
     (license license:gpl2+)))
+
+(define-public qview
+  (package
+    (name "qview")
+    (version "2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jurplel/qView.git")
+                    (commit version)))
+              (sha256
+               (base32
+                "1s29hz44rb5dwzq8d4i4bfg77dr0v3ywpvidpa6xzg7hnnv3mhi5"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _
+             (invoke "qmake")))
+         ;; Installation process hard-codes "/usr/bin", possibly
+         ;; prefixed.
+         (add-after 'configure 'fix-install-directory
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (substitute* "Makefile"
+                 (("\\$\\(INSTALL_ROOT\\)/usr") out))
+               #t)))
+         ;; Don't phone home or show "Checking for updates..." in the
+         ;; About menu.
+         (add-before 'build 'disable-auto-update
+           (lambda _
+             (substitute* "src/qvaboutdialog.cpp"
+               (("ui->updateLabel->setText\\(updateText\\);") "")
+               (("requestUpdates\\(\\);") ""))
+             #t)))))
+    (inputs
+     `(("qtbase" ,qtbase)
+       ("qtsvg" ,qtsvg)
+       ("qtimageformats" ,qtimageformats)))
+    (home-page "https://interversehq.com/qview/")
+    (synopsis "Practical and minimal image viewer")
+    (description "qView is a Qt image viewer designed with visually
+minimalism and usability in mind.  Its features include animated GIF
+controls, file history, rotation/mirroring, and multithreaded
+preloading.")
+    (license license:gpl3+)))