diff mbox series

[bug#35950,2/3] gnu: python-flask-restful: Update to 0.12.1.

Message ID 20190528213259.7ceed1db@scratchpost.org
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Danny Milosavljevic May 28, 2019, 7:32 p.m. UTC
It doesn't actually build for me.

I made the following changes, but it still doesn't build.  Did it build for you?

Comments

Hamzeh Nasajpour May 31, 2019, 7:07 p.m. UTC | #1
Yes, it built for me.

On Wed, May 29, 2019, at 12:03 AM, Danny Milosavljevic wrote:
> It doesn't actually build for me.
> 
> I made the following changes, but it still doesn't build.  Did it build for you?
> 
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 6518d841c8..adb18cc7d0 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -2110,6 +2110,7 @@ pretty printer and a tree visitor.")
>      (propagated-inputs
>        `(("python-aniso8601" ,python-aniso8601)
>          ("python-flask" ,python-flask)
> +        ("python-jsonschema" ,python-jsonschema)
>          ("python-pycrypto" ,python-pycrypto)
>          ("python-pytz" ,python-pytz)))
>      (native-inputs
> @@ -2117,7 +2118,9 @@ pretty printer and a tree visitor.")
>          ("python-blinker" ,python-blinker)
>          ("python-mock" ,python-mock) ; For tests
>          ("python-nose" ,python-nose) ; For tests
> -        ("python-sphinx" ,python-sphinx)))
> +        ("python-pytest-sugar" ,python-pytest-sugar) ; For tests
> +        ("python-sphinx" ,python-sphinx)
> +        ("python-tzlocal" ,python-tzlocal))) ; For tests
>      (home-page
>        "https://www.github.com/flask-restful/flask-restful/")
>      (synopsis
>
Ludovic Courtès June 13, 2019, 8:40 a.m. UTC | #2
Hi Hamzeh,

The initial patch fails for me as well on
76533c52c06de4823738b32e450a1a06522018d1:

--8<---------------cut here---------------start------------->8---
building /gnu/store/p7f17fczgwqav50r7fz5rd13z011rrm0-python-flask-restful-0.12.1.drv...

[…]

starting phase `check'
running "python setup.py" with command "test" and parameters ()
running test
Searching for jsonschema
Reading https://pypi.python.org/simple/jsonschema/
Download error on https://pypi.python.org/simple/jsonschema/: [Errno -2] Name or service not known -- Some packages may not be found!
Couldn't find index page for 'jsonschema' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
Download error on https://pypi.python.org/simple/: [Errno -2] Name or service not known -- Some packages may not be found!
No local packages or working download links found for jsonschema
error: Could not find suitable distribution for Requirement.parse('jsonschema')
--8<---------------cut here---------------end--------------->8---

This confirms that we at least need ‘python-jsonschema’ as an extra
dependency, as Danny’s patch does.

Could you investigate and submit an updated patch?

Thank you,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6518d841c8..adb18cc7d0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2110,6 +2110,7 @@  pretty printer and a tree visitor.")
     (propagated-inputs
       `(("python-aniso8601" ,python-aniso8601)
         ("python-flask" ,python-flask)
+        ("python-jsonschema" ,python-jsonschema)
         ("python-pycrypto" ,python-pycrypto)
         ("python-pytz" ,python-pytz)))
     (native-inputs
@@ -2117,7 +2118,9 @@  pretty printer and a tree visitor.")
         ("python-blinker" ,python-blinker)
         ("python-mock" ,python-mock) ; For tests
         ("python-nose" ,python-nose) ; For tests
-        ("python-sphinx" ,python-sphinx)))
+        ("python-pytest-sugar" ,python-pytest-sugar) ; For tests
+        ("python-sphinx" ,python-sphinx)
+        ("python-tzlocal" ,python-tzlocal))) ; For tests
     (home-page
       "https://www.github.com/flask-restful/flask-restful/")
     (synopsis