diff mbox series

[bug#35928] gnu: Add osmctools

Message ID 20190527150516.6762-1-glv@posteo.net
State Accepted
Headers show
Series [bug#35928] gnu: Add osmctools | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Guillaume Le Vaillant May 27, 2019, 3:05 p.m. UTC
* gnu/packages/geo.scm (osmctools): New public variable.
---
 gnu/packages/geo.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Leo Famulari May 27, 2019, 6:37 p.m. UTC | #1
On Mon, May 27, 2019 at 05:05:16PM +0200, Guillaume LE VAILLANT wrote:
> * gnu/packages/geo.scm (osmctools): New public variable.

Thanks!

Pushed as ed72a133dbba02cd1d49a19e0a6391ce9384840e with the following
changes:

> +    (description "This project contains a few simple tools which are used in
> +the OpenStreetMap project. They can be used to convert, filter and update
> +OpenStreetMap data files.")

`guix environment guix -- ./pre-inst-env guix lint osmctools` complained
about a minor formatting issue in the description:

"gnu/packages/geo.scm:868:17: osmctools@0.9: sentences in description should be followed by two spaces; possible infraction at 84"

Also, I removed the word "simple" in accordance with our guidelines
about synopses and descriptions [0] — specifically the part about using
"marketing phrases". It's a minor nitpick but I was already editing the
description... :)

Thank you very much for your contribution!

[0]
https://www.gnu.org/software/guix/manual/en/html_node/Synopses-and-Descriptions.html
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 94f2cf0cfb..a18677fc49 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,7 @@ 
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix utils)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -840,3 +842,30 @@  map, geocoding with Nominatim, or general analysis.")
 the texture and density of features is visible at every zoom level, instead of
 dropping features at lower levels.")
     (license license:bsd-2)))
+
+(define-public osmctools
+  (package
+    (name "osmctools")
+    (version "0.9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/osm-c-tools/osmctools")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1m8d3r1q1v05pkr8k9czrmb4xjszw6hvgsf3kn9pf0v14gpn4r8f"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)))
+    (inputs
+     `(("zlib" ,zlib)))
+    (home-page "https://gitlab.com/osm-c-tools/osmctools")
+    (synopsis "Tools to convert, filter and update OpenStreetMap data files")
+    (description "This project contains a few simple tools which are used in
+the OpenStreetMap project. They can be used to convert, filter and update
+OpenStreetMap data files.")
+    (license license:agpl3)))