diff mbox series

[bug#35922] gnu: add terminator

Message ID 20190527074613.25582-1-atai@atai.org
State Accepted
Headers show
Series [bug#35922] gnu: add terminator | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Andy Tai May 27, 2019, 7:46 a.m. UTC
From: Andy Tai <atai@atai.org>

* gnu/packages/gnome.scm (terminator): Add at 1.91
---
 gnu/packages/gnome.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Ludovic Courtès May 29, 2019, 9:10 p.m. UTC | #1
Hello,

atai@atai.org skribis:

> From: Andy Tai <atai@atai.org>
>
> * gnu/packages/gnome.scm (terminator): Add at 1.91

[...]

> +    (arguments
> +     `(#:python ,python-2))

Python 2.x is reaching EOL real soon.  Can it run on Python 3?

> +    (description
> +     "A tool to allow running multiple GNOME terminals in a grid and
> +     tabs and support for drag and drop re-ordering of terminals")

Could you make a full sentence and remove the trailing spaces?  See
<https://www.gnu.org/software/guix/manual/en/html_node/Synopses-and-Descriptions.html>.

> +    (license license:gpl2)))

This means “version 2 only”.  Is there an explicit “version 2 only”
statement, for example in source file headers?  If not, it should be
‘gpl2+’.

Could you send an updated patch?

Thank you,
Ludo’.
Andy Tai May 30, 2019, 5:58 a.m. UTC | #2
On Wed, May 29, 2019 at 2:10 PM Ludovic Courtès <ludo@gnu.org> wrote:

> Hello,
>
> atai@atai.org skribis:
>
> > From: Andy Tai <atai@atai.org>
> >
> > * gnu/packages/gnome.scm (terminator): Add at 1.91
>
> [...]
>
> > +    (arguments
> > +     `(#:python ,python-2))
>
> Python 2.x is reaching EOL real soon.  Can it run on Python 3?
>

hi, no, not the current upstream... I tried with python-3 and won't run

>
> > +    (description
> > +     "A tool to allow running multiple GNOME terminals in a grid and
> > +     tabs and support for drag and drop re-ordering of terminals")
>
> Could you make a full sentence and remove the trailing spaces?  See
> <
> https://www.gnu.org/software/guix/manual/en/html_node/Synopses-and-Descriptions.html
> >.
>
> will update


> > +    (license license:gpl2)))
>
> This means “version 2 only”.  Is there an explicit “version 2 only”
> statement, for example in source file headers?  If not, it should be
> ‘gpl2+’.
>
> source clearly labeled gpl "Version 2 Only"

> Could you send an updated patch?
>
> will do

> Thank you,
> Ludo’.
>
Ricardo Wurmus May 30, 2019, 9:54 a.m. UTC | #3
Ludovic Courtès <ludo@gnu.org> writes:

> Hello,
>
> atai@atai.org skribis:
>
>> From: Andy Tai <atai@atai.org>
>>
>> * gnu/packages/gnome.scm (terminator): Add at 1.91
>
> [...]
>
>> +    (arguments
>> +     `(#:python ,python-2))
>
> Python 2.x is reaching EOL real soon.  Can it run on Python 3?

It looks like terminator is no longer maintained since 2017.
Andy Tai May 31, 2019, 4:58 a.m. UTC | #4
Hi, this is a popular program used by many people and in repos of Fedora
and Ubuntu.  2017 was only 2 years ago, so "not maintained" for two years
seems not unusual in the Free Software world.   In any case, that would not
prevent other python2 programs from being in Guix or other GNU/Linux
distributions.   Migration to Python 3 would be issue for the upstream or
for anyone taking over maintenance, common for widely used programs if the
needs rises.

On Thu, May 30, 2019 at 2:55 AM Ricardo Wurmus <rekado@elephly.net> wrote:

>
> Ludovic Courtès <ludo@gnu.org> writes:
>
> > Hello,
> >
> > atai@atai.org skribis:
> >
> >> From: Andy Tai <atai@atai.org>
> >>
> >> * gnu/packages/gnome.scm (terminator): Add at 1.91
> >
> > [...]
> >
> >> +    (arguments
> >> +     `(#:python ,python-2))
> >
> > Python 2.x is reaching EOL real soon.  Can it run on Python 3?
>
> It looks like terminator is no longer maintained since 2017.
>
> --
> Ricardo
>
>
Ricardo Wurmus May 31, 2019, 7:52 a.m. UTC | #5
Hi Andy,

> Hi, this is a popular program used by many people and in repos of Fedora
> and Ubuntu.  2017 was only 2 years ago, so "not maintained" for two years
> seems not unusual in the Free Software world.

Sure.  What I meant is that it’s unlikely that upstream will migrate it
to Python 3 and by the time Python 2 hits EOL this will be our problem.
Andy Tai May 31, 2019, 3:44 p.m. UTC | #6
Rewrite in guile?:)

On Fri, May 31, 2019, 12:53 AM Ricardo Wurmus <rekado@elephly.net> wrote:

>
> Hi Andy,
>
> > Hi, this is a popular program used by many people and in repos of Fedora
> > and Ubuntu.  2017 was only 2 years ago, so "not maintained" for two years
> > seems not unusual in the Free Software world.
>
> Sure.  What I meant is that it’s unlikely that upstream will migrate it
> to Python 3 and by the time Python 2 hits EOL this will be our problem.
>
> --
> Ricardo
>
>
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6a2a683f58..77269ba503 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2019 Li-Cheng (Andy) Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -162,6 +163,7 @@ 
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
+  #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -7973,3 +7975,40 @@  functionality.")
     (license (list license:lgpl2.1 license:lgpl3 ; either one of these
                    license:openldap2.8 ; addressbook/gui/component/openldap-extract.h
                    license:lgpl2.1+))))  ; smime/lib/*
+
+(define-public terminator
+  (package
+    (name "terminator")
+    (version "1.91")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://launchpad.net/" name "/"
+                                  "gtk3/" version "/" "+download/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0sdyqwydmdnh7j6mn74vrywz35m416kqsbxbrqcnv5ak08y6xxwm"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("glib" ,glib "bin")
+       ("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)       
+       ("gtk+" ,gtk+)
+       ("gobject-introspection" ,gobject-introspection)
+       ("pango" ,pango)
+       ("python" ,python-2)
+       ("python2-pycairo" ,python2-pycairo)
+       ("python2-pygobject" ,python2-pygobject)
+       ("python2-psutil" ,python2-psutil)
+       ("vte" ,vte)))
+    (arguments
+     `(#:python ,python-2))
+    (home-page "https://gnometerminator.blogspot.com/")
+    (synopsis "Store and run multiple GNOME terminals in one window")
+    (description
+     "A tool to allow running multiple GNOME terminals in a grid and
+     tabs and support for drag and drop re-ordering of terminals")
+    (license license:gpl2)))