diff mbox series

[bug#35897] gnu: sddm: add QtQuick related dependencies tosddm

Message ID 20190525130913.3242-1-r.majd@pantherx.org
State Accepted
Headers show
Series [bug#35897] gnu: sddm: add QtQuick related dependencies tosddm | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Reza Alizadeh Majd May 25, 2019, 1:09 p.m. UTC
* gnu/packages/display-managers.scm (sddm): add QtQuick related
dependencist to sddm package in order to `sddm-greeter` application
to load user defined themes which are based on QtQuick.
---
 gnu/packages/display-managers.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Reza Alizadeh Majd May 25, 2019, 1:27 p.m. UTC | #1
Hi, 

a series of SDDM user defined themes are using QtQuick components internally. 

Since `sddm-greeter` loads these themes dynamically, we also need to add these
QtQuick related libraries to QML2_IMPORT_PATH. so I’ve added these libraries 
as sddm package inputs, to be wrapped by wrap-qt-program. 


Regards,
Reza
Ludovic Courtès May 29, 2019, 8:57 p.m. UTC | #2
Hello,

"Reza Alizadeh Majd" <r.majd@pantherx.org> skribis:

> a series of SDDM user defined themes are using QtQuick components internally. 
>
> Since `sddm-greeter` loads these themes dynamically, we also need to add these
> QtQuick related libraries to QML2_IMPORT_PATH. so I’ve added these libraries 
> as sddm package inputs, to be wrapped by wrap-qt-program. 

OK.  I took the liberty to add these explanations as a comment and
committed.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 29d8ae4eb9..725a3c5473 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -75,6 +75,10 @@ 
        ("linux-pam" ,linux-pam)
        ("qtbase" ,qtbase)
        ("qtdeclarative" ,qtdeclarative)
+       ("qtgraphicaleffects" ,qtgraphicaleffects)
+       ("qtquickcontrols" ,qtquickcontrols)
+       ("qtquickcontrols2" ,qtquickcontrols2)
+       ("qtsvg" ,qtsvg)
        ("shadow" ,shadow)
        ("wayland" ,wayland)))
     (arguments