diff mbox series

[bug#35854] lxqt: lxqt-panel: fix taskbar plugin'sapplication list issue.

Message ID 20190522072716.11256-1-r.majd@pantherx.org
State Accepted
Headers show
Series [bug#35854] lxqt: lxqt-panel: fix taskbar plugin'sapplication list issue. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Reza Alizadeh Majd May 22, 2019, 7:27 a.m. UTC
* gnu/packages/lxqt.scm (lxqt-panel): move `kwindowsystem` from `inputs`
to `propagated-inputs`
---
 gnu/packages/lxqt.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Reza Alizadeh Majd May 22, 2019, 8:03 a.m. UTC | #1
list of opened applications wouldn't show in lxqt-panel's taskbar plugin, 
since `kwindowsystem` is responsible for that, moving this library from 
`inputs` to `propagated-inputs` fixed this issue.
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index d91efe715d..a03a93e5c5 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2019 Meiyo Peng <meiyo@riseup.net>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Reza Alizadeh Majd <r.majd@pantherx.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -559,7 +560,6 @@  of other programs.")
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("kguiaddons" ,kguiaddons)
-       ("kwindowsystem" ,kwindowsystem)
        ("libdbusmenu-qt" ,libdbusmenu-qt)
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
@@ -582,6 +582,8 @@  of other programs.")
      `(("pkg-config" ,pkg-config)
        ("lxqt-build-tools" ,lxqt-build-tools)
        ("qttools" ,qttools)))
+    (propagated-inputs
+      `(("kwindowsystem" ,kwindowsystem)))
     (arguments
      '(#:tests? #f                      ; no tests
        #:phases