diff mbox series

[bug#35804] libnotify didn't have propagated-inputs

Message ID 20190519232207.i7xdlzrptnjwhvqk@keter.Dlink
State Accepted
Headers show
Series [bug#35804] libnotify didn't have propagated-inputs | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Uko Kokņevičs May 19, 2019, 11:23 p.m. UTC
libnotify doesn't propagate other needed libraries for linking against
it resulting in pkg-config errors like

> Package gdk-pixbuf-2.0 was not found in the pkg-config search path.
> Perhaps you should add the directory containing `gdk-pixbuf-2.0.pc'
> to the PKG_CONFIG_PATH environment variable

The following patch should fix that.


From 4cb942cd6b5389c29fa80d9af8442c3fa364406f Mon Sep 17 00:00:00 2001
From: Uko Koknevics <perkontevs@gmail.com>
Date: Mon, 20 May 2019 01:49:05 +0300
Subject: [PATCH] Added propagated-inputs to libnotify

---
 gnu/packages/gnome.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

--
2.21.0

Comments

Marius Bakke May 21, 2019, 3:29 p.m. UTC | #1
Hi Uko,

Uko Kokņevičs <perkontevs@gmail.com> writes:

> libnotify doesn't propagate other needed libraries for linking against
> it resulting in pkg-config errors like
>
>> Package gdk-pixbuf-2.0 was not found in the pkg-config search path.
>> Perhaps you should add the directory containing `gdk-pixbuf-2.0.pc'
>> to the PKG_CONFIG_PATH environment variable
>
> The following patch should fix that.

Thank you!  I added a commit message that follows our convention, and
left a comment in the code explaining why these have to be propagated.

Pushed as 7ef08efa21900e6e43415b9f9db0e51a04e17fa5.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9070673..9c0cce9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1108,10 +1108,11 @@  configuring CUPS.")
        (base32
         "017wgq9n00hx39n0hm784zn18hl721hbaijda868cm96bcqwxd4w"))))
     (build-system gnu-build-system)
-    (inputs
+    (propagated-inputs
      `(("gdk-pixbuf" ,gdk-pixbuf)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
+       ("glib" ,glib)))
+    (inputs
+     `(("gtk+" ,gtk+)
        ("libpng" ,libpng)))
     (native-inputs
       `(("pkg-config" ,pkg-config)