diff mbox series

[bug#35792,2/7] gnu: Add smithwaterman.

Message ID 20190518172640.7165-2-mail@ambrevar.xyz
State Accepted
Headers show
Series Package freebayes | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Pierre Neidhardt May 18, 2019, 5:26 p.m. UTC
* gnu/packages/bioinformatics.scm (smithwaterman): New variable.
---
 gnu/packages/bioinformatics.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Ricardo Wurmus Aug. 8, 2019, 2:30 p.m. UTC | #1
Pierre Neidhardt <mail@ambrevar.xyz> writes:

> * gnu/packages/bioinformatics.scm (smithwaterman): New variable.
[…]
> +      ;; The licensing terms are unclear: https://github.com/ekg/smithwaterman/issues/9.
> +      (license (list license:gpl2 license:expat)))))

If the licensing terms are unclear we should not include this package.

--
Ricardo
Efraim Flashner Aug. 8, 2019, 4:29 p.m. UTC | #2
https://github.com/ekg/smithwaterman/issues/9#issuecomment-493694384

Between the two licenses it's GPL2. The expat license text just hasn't been removed.

On August 8, 2019 2:30:24 PM UTC, Ricardo Wurmus <rekado@elephly.net> wrote:
>
>Pierre Neidhardt <mail@ambrevar.xyz> writes:
>
>> * gnu/packages/bioinformatics.scm (smithwaterman): New variable.
>[…]
>> +      ;; The licensing terms are unclear:
>https://github.com/ekg/smithwaterman/issues/9.
>> +      (license (list license:gpl2 license:expat)))))
>
>If the licensing terms are unclear we should not include this package.
>
>--
>Ricardo
Ricardo Wurmus Aug. 8, 2019, 4:31 p.m. UTC | #3
Efraim Flashner <efraim@flashner.co.il> writes:

> https://github.com/ekg/smithwaterman/issues/9#issuecomment-493694384
>
> Between the two licenses it's GPL2. The expat license text just hasn't been removed.

Okay, that makes sense.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 244741854d..1bf33853b0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14869,3 +14869,33 @@  might be caused by ATAC-seq library prep or sequencing.  The main program,
    (description "This is a C++ wrapper around the Tabix project which abstracts
 some of the details of opening and jumping in tabix-indexed files.")
    (license license:expat)))
+
+(define-public smithwaterman
+  ;; TODO: Upgrading smithwaterman breaks FreeBayes.
+  (let ((commit "203218b47d45ac56ef234716f1bd4c741b289be1"))
+    (package
+      (name "smithwaterman")
+      (version (string-append "0-1." (string-take commit 7)))
+      (source (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/ekg/smithwaterman/")
+              (commit commit)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0z9xsmsv452kgdfbbwydyc6nymg3fwyv8zswls8qjin3r4ia4415"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ; There are no tests to run.
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure) ; There is no configure phase.
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+                 (install-file "smithwaterman" bin)))))))
+      (home-page "https://github.com/ekg/smithwaterman")
+      (synopsis "Implementation of the Smith-Waterman algorithm")
+      (description "Implementation of the Smith-Waterman algorithm.")
+      ;; The licensing terms are unclear: https://github.com/ekg/smithwaterman/issues/9.
+      (license (list license:gpl2 license:expat)))))