diff mbox series

[bug#35789] gnu: lxqt-session: fix lxqt-rc.xml permissionissue

Message ID 20190518090229.22339-1-r.majd@pantherx.org
State Accepted
Headers show
Series [bug#35789] gnu: lxqt-session: fix lxqt-rc.xml permissionissue | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Reza Alizadeh Majd May 18, 2019, 9:02 a.m. UTC
* gnu/packages/lxqt.scm (lxqt-session): change lxqt-rc.xml permission to
755 after initial copy to user directory.
---
 gnu/packages/lxqt.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Reza Alizadeh Majd May 18, 2019, 10:22 a.m. UTC | #1
Hi Guix, 

Based on issue that I submitted before 
( http://lists.gnu.org/archive/html/help-guix/2019-05/msg00372.html ) ,
lxqt-session copies an openbox related file (lxqt-rc.xml) to user's home directory, 
since this file permissions are set as readonly in `gnu/store`, users are unable to 
modify this file using openbox settings GUI, for this I submitted following patch to 
set proper permessions to `lxqt-rc.xml` file after initial copy to user's home 
directory.
Ludovic Courtès May 21, 2019, 2:30 p.m. UTC | #2
Hello,

Reza Alizadeh Majd <r.majd@pantherx.org> skribis:

> * gnu/packages/lxqt.scm (lxqt-session): change lxqt-rc.xml permission to
> 755 after initial copy to user directory.

[...]

> +             (substitute* "startlxqt.in"
> +               (("cp \"\\$LXQT_DEFAULT_OPENBOX_CONFIG\" \"\\$XDG_CONFIG_HOME/openbox\"")
> +                 (string-append "cp \"$LXQT_DEFAULT_OPENBOX_CONFIG\" \"$XDG_CONFIG_HOME/openbox\"\n"
> +                                "        # fix openbox permission issue\n"
> +                                "        chmod -R 755 \"$XDG_CONFIG_HOME/openbox\"")))

That will make every file executable.

What about just:

  chmod u+w "$XDG_CONFIG_HOME/openbox"/*

?

One last thing: could you provide the explanation you gave in just one
or two lines of comment right above this ‘substitute*’ expression?

Thank you,
Ludo’.
Reza Alizadeh Majd May 21, 2019, 6:23 p.m. UTC | #3
Hi, 

>   chmod u+w "$XDG_CONFIG_HOME/openbox"/*

you're right, setting the write permission to lxqt-rc.xml is preferred.

I also add a comment line before permission modification phase and amend 
my last commit. 


Best, 
Reza
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index d91efe715d..94d47bc862 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -827,6 +827,14 @@  allows for launching applications or shutting down the system.")
                (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
                 "DESTINATION \"etc/xdg"))
              #t))
+         (add-after 'unpack 'patch-openbox-permission
+           (lambda _
+             (substitute* "startlxqt.in"
+               (("cp \"\\$LXQT_DEFAULT_OPENBOX_CONFIG\" \"\\$XDG_CONFIG_HOME/openbox\"")
+                 (string-append "cp \"$LXQT_DEFAULT_OPENBOX_CONFIG\" \"$XDG_CONFIG_HOME/openbox\"\n"
+                                "        # fix openbox permission issue\n"
+                                "        chmod -R 755 \"$XDG_CONFIG_HOME/openbox\"")))
+             #t))
          (add-after 'unpack 'patch-translations-dir
            (lambda* (#:key outputs #:allow-other-keys)
              (substitute* '("lxqt-config-session/CMakeLists.txt"