diff mbox series

[bug#35707] gnu: Add lemonbar package

Message ID 20190513045721.12410-1-nnoodle@chiru.no
State Accepted
Headers show
Series [bug#35707] gnu: Add lemonbar package | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Noodles! May 13, 2019, 4:57 a.m. UTC
---
 gnu/packages/wm.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

swedebugia June 25, 2019, 8:59 p.m. UTC | #1
On 2019-05-13 06:57, Noodles! wrote:
> +(define-public lemonbar
> +  (let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
> +        (revision "1"))
> +    (package
> +     (name "lemonbar")
> +     (version (git-version "1.3" revision commit))
> +     (source (origin
> +               (method git-fetch)
> +               (uri (git-reference
> +                     (url"https://github.com/LemonBoy/bar")
> +                     (commit commit)))
> +               (file-name (git-file-name name version))
> +               (sha256
> +                (base32
> +                 "1wwqbph392iwz8skaqxb0xpklb1l6yganqz80g4x1fhrnz7idmlh"))))
> +     (build-system gnu-build-system)
> +     (arguments
> +      '(#:tests? #f
> +        #:make-flags (list "CC=gcc"
> +                      (string-append "PREFIX=" %output))
> +        #:phases
> +        (modify-phases %standard-phases
> +          (delete 'configure))))
> +     (inputs
> +      `(("libxcb" ,libxcb)))
> +     (native-inputs
> +      `(("perl" ,perl)))
> +     (home-page"https://github.com/LemonBoy/bar")
> +     (synopsis "Featherweight status bar")
> +     (description
> +      "@code{lemonbar} (formerly known as @code{bar}) is a lightweight
> +bar entirely based on XCB.  Provides full UTF-8 support, basic
> +formatting, RandR and Xinerama support and EWMH compliance without
> +wasting your precious memory.")
> +     (license license:x11))))

It did not apply because of patch age.

I applied it manually. LGTM!

Thanks.
Brett Gilio Dec. 10, 2019, 5:51 a.m. UTC | #2
Pushed with commit d4145638631f2ebe94fa93fef326da83dd85732b.

Because this patch was outdated it could not merge automatically. I took
the liberty to make sure this patch could be merged, made sure all
details are up-to-date, that the tests are commented as to why they are
disabled, linted it, and pushed it with a proper commit message.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 0a05ff4ae..6c727e36c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2019 Noodles! <nnoodle@chiru.no>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1087,6 +1088,42 @@  customizable status bars for their desktop environment.  It has built-in
 functionality to display information about the most commonly used services.")
     (license license:expat)))
 
+(define-public lemonbar
+  (let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
+        (revision "1"))
+    (package
+     (name "lemonbar")
+     (version (git-version "1.3" revision commit))
+     (source (origin
+               (method git-fetch)
+               (uri (git-reference
+                     (url "https://github.com/LemonBoy/bar")
+                     (commit commit)))
+               (file-name (git-file-name name version))
+               (sha256
+                (base32
+                 "1wwqbph392iwz8skaqxb0xpklb1l6yganqz80g4x1fhrnz7idmlh"))))
+     (build-system gnu-build-system)
+     (arguments
+      '(#:tests? #f
+        #:make-flags (list "CC=gcc"
+                      (string-append "PREFIX=" %output))
+        #:phases
+        (modify-phases %standard-phases
+          (delete 'configure))))
+     (inputs
+      `(("libxcb" ,libxcb)))
+     (native-inputs
+      `(("perl" ,perl)))
+     (home-page "https://github.com/LemonBoy/bar")
+     (synopsis "Featherweight status bar")
+     (description
+      "@code{lemonbar} (formerly known as @code{bar}) is a lightweight
+bar entirely based on XCB.  Provides full UTF-8 support, basic
+formatting, RandR and Xinerama support and EWMH compliance without
+wasting your precious memory.")
+     (license license:x11))))
+
 (define-public wlroots
   (package
     (name "wlroots")