diff mbox series

[bug#35677,1/3] gnu: Move Linux-Libre modules to their ownsection.

Message ID 20190510212818.7996-1-me@tobias.gr
State Accepted
Headers show
Series [bug#35677,1/3] gnu: Move Linux-Libre modules to their ownsection. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Tobias Geerinckx-Rice May 10, 2019, 9:28 p.m. UTC
* gnu/packages/linux.scm (vhba-module): Move to its own section.
---
 gnu/packages/linux.scm | 49 +++++++++++++++++++++++-------------------
 1 file changed, 27 insertions(+), 22 deletions(-)

Comments

Tobias Geerinckx-Rice May 20, 2019, 2:23 a.m. UTC | #1
Pushed as e1f640db8fa2a3aee018ce80df47b37e245c4b52 &c.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4e08bd0ae3..a3a2615834 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -440,28 +440,6 @@  It has been modified to remove all non-free binary blobs.")
                     #:patches %linux-libre-5.0-patches
                     #:configuration-file kernel-config))
 
-(define-public vhba-module
-  (package
-    (name "vhba-module")
-    (version "20190410")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "http://downloads.sourceforge.net/cdemu/vhba-module/vhba-module-"
-                    version ".tar.bz2"))
-              (sha256
-               (base32
-                "1513hq130raxp9z5grj54cwfjfxj05apipxg425j0zicii59a60c"))))
-    (build-system linux-module-build-system)
-    (arguments
-     ;; TODO: No tests?
-     `(#:tests? #f))
-    (home-page "https://cdemu.sourceforge.io/")
-    (synopsis "Kernel module that emulates SCSI devices")
-    (description "VHBA module provides a Virtual (SCSI) HBA, which is the link
-between the CDemu userspace daemon and linux kernel.")
-    (license license:gpl2+)))
-
 (define %linux-libre-4.19-version "4.19.41")
 (define %linux-libre-4.19-hash "0lf1w72y4qkrg57qd78zs16r658qaqzwly0y9195nf7bdwqzb03v")
 
@@ -558,6 +536,33 @@  between the CDemu userspace daemon and linux kernel.")
                     #:extra-version "arm-omap2plus"))
 
 
+;;;
+;;; Linux kernel modules.
+;;;
+
+(define-public vhba-module
+  (package
+    (name "vhba-module")
+    (version "20190410")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://downloads.sourceforge.net/cdemu/vhba-module/vhba-module-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "1513hq130raxp9z5grj54cwfjfxj05apipxg425j0zicii59a60c"))))
+    (build-system linux-module-build-system)
+    (arguments
+     ;; TODO: No tests?
+     `(#:tests? #f))
+    (home-page "https://cdemu.sourceforge.io/")
+    (synopsis "Kernel module that emulates SCSI devices")
+    (description "VHBA module provides a Virtual (SCSI) HBA, which is the link
+between the CDemu userspace daemon and linux kernel.")
+    (license license:gpl2+)))
+
+
 ;;;
 ;;; Pluggable authentication modules (PAM).
 ;;;