diff mbox series

[bug#35653,v2] gnu: Add rcm.

Message ID 20190509175916.22479-2-josh@inv.alid.pw
State Accepted
Headers show
Series [bug#35653,v2] gnu: Add rcm. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Josh Holland May 9, 2019, 5:59 p.m. UTC
* gnu/packages/rcm.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add rcm.scm.
---
 gnu/local.mk         |  1 +
 gnu/packages/rcm.scm | 62 ++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 63 insertions(+)
 create mode 100644 gnu/packages/rcm.scm

Comments

Brett Gilio Dec. 10, 2019, 6:55 a.m. UTC | #1
Josh Holland <josh@inv.alid.pw> writes:

> * gnu/packages/rcm.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add rcm.scm.
> ---
>  gnu/local.mk         |  1 +
>  gnu/packages/rcm.scm | 62 ++++++++++++++++++++++++++++++++++++++++++++
>  2 files changed, 63 insertions(+)
>  create mode 100644 gnu/packages/rcm.scm
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 3f97397c4a..0789d74f78 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -398,6 +398,7 @@ GNU_SYSTEM_MODULES =				\
>    %D%/packages/ragel.scm			\
>    %D%/packages/rails.scm			\
>    %D%/packages/ratpoison.scm			\
> +  %D%/packages/rcm.scm				\
>    %D%/packages/rdesktop.scm			\
>    %D%/packages/rdf.scm				\
>    %D%/packages/re2c.scm				\
> diff --git a/gnu/packages/rcm.scm b/gnu/packages/rcm.scm
> new file mode 100644
> index 0000000000..c61626d114
> --- /dev/null
> +++ b/gnu/packages/rcm.scm
> @@ -0,0 +1,62 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages rcm)
> +  #:use-module (guix packages)
> +  #:use-module (guix download)
> +  #:use-module (guix build-system gnu)
> +  #:use-module (guix licenses)
> +  #:use-module (gnu packages python-xyz)
> +  #:use-module (gnu packages perl))
> +
> +(define-public rcm
> +  (package
> +    (name "rcm")
> +    (version "1.3.3")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://thoughtbot.github.io/rcm/dist/rcm-"
> +                                  version ".tar.gz"))
> +              (sha256
> +               (base32 "1bqk7rrp1ckzvsvl9wghsr77m8xl3a7yc5gqdsisz492dx2j8mck"))))
> +    (build-system gnu-build-system)
> +    (arguments '(#:phases
> +                 (modify-phases %standard-phases
> +                   (add-after 'patch-source-shebangs 'patch-tests
> +                     (lambda _
> +                       (substitute* '("test/rcrc-tilde.t"
> +                                      "test/rcdn-hooks-run-in-order.t"
> +                                      "test/rcup-hooks-run-in-order.t")
> +                         (("/bin/sh") (which "sh")))
> +                       (substitute* "test/rcup-hooks.t"
> +                         (("/usr/bin/env") (which "env")))
> +                       #t)))
> +                  #:parallel-tests? #f))
> +    (native-inputs `(("perl" ,perl)
> +                     ("python-cram" ,python-cram)))
> +    (synopsis "Management suite for dotfiles")
> +    (description "The rcm suite of tools is for managing dotfiles directories.  This is
> +a directory containing all the @code{.*rc} files in your home directory
> +(@code{.zshrc}, @code{.vimrc}, and so on). These files have gone by many
> +names in history, such as “rc files” because they typically end in rc
> +or “dotfiles” because they begin with a period.  This suite is useful
> +for committing your rc files to a central repository to share, but it also
> +scales to a more complex situation such as multiple source directories
> +shared between computers with some host-specific or task-specific files.")
> +    (license bsd-3)
> +    (home-page "https://github.com/thoughtbot/rcm")))

This all LGTM! Is there any objections to pushing this? I will if it
looks good to everbody else!
Ludovic Courtès Jan. 15, 2020, 9:42 p.m. UTC | #2
Hi,

Josh Holland <josh@inv.alid.pw> skribis:

> * gnu/packages/rcm.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add rcm.scm.

Applied, thanks, and sorry for the delay!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 3f97397c4a..0789d74f78 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -398,6 +398,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/ragel.scm			\
   %D%/packages/rails.scm			\
   %D%/packages/ratpoison.scm			\
+  %D%/packages/rcm.scm				\
   %D%/packages/rdesktop.scm			\
   %D%/packages/rdf.scm				\
   %D%/packages/re2c.scm				\
diff --git a/gnu/packages/rcm.scm b/gnu/packages/rcm.scm
new file mode 100644
index 0000000000..c61626d114
--- /dev/null
+++ b/gnu/packages/rcm.scm
@@ -0,0 +1,62 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rcm)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix licenses)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages perl))
+
+(define-public rcm
+  (package
+    (name "rcm")
+    (version "1.3.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://thoughtbot.github.io/rcm/dist/rcm-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32 "1bqk7rrp1ckzvsvl9wghsr77m8xl3a7yc5gqdsisz492dx2j8mck"))))
+    (build-system gnu-build-system)
+    (arguments '(#:phases
+                 (modify-phases %standard-phases
+                   (add-after 'patch-source-shebangs 'patch-tests
+                     (lambda _
+                       (substitute* '("test/rcrc-tilde.t"
+                                      "test/rcdn-hooks-run-in-order.t"
+                                      "test/rcup-hooks-run-in-order.t")
+                         (("/bin/sh") (which "sh")))
+                       (substitute* "test/rcup-hooks.t"
+                         (("/usr/bin/env") (which "env")))
+                       #t)))
+                  #:parallel-tests? #f))
+    (native-inputs `(("perl" ,perl)
+                     ("python-cram" ,python-cram)))
+    (synopsis "Management suite for dotfiles")
+    (description "The rcm suite of tools is for managing dotfiles directories.  This is
+a directory containing all the @code{.*rc} files in your home directory
+(@code{.zshrc}, @code{.vimrc}, and so on). These files have gone by many
+names in history, such as “rc files” because they typically end in rc
+or “dotfiles” because they begin with a period.  This suite is useful
+for committing your rc files to a central repository to share, but it also
+scales to a more complex situation such as multiple source directories
+shared between computers with some host-specific or task-specific files.")
+    (license bsd-3)
+    (home-page "https://github.com/thoughtbot/rcm")))