@@ -2283,6 +2283,36 @@ It can read a subset of yaml and is not capable of write yaml")
e.g. creating a Python package project from a Python package project template.")
(license license:bsd-3)))
+(define-public python-mesa
+ (package
+ (name "python-mesa")
+ (version "0.8.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Mesa" version))
+ (sha256
+ (base32
+ "0qn7gsv1ni5ccm6r6k02m94m4n6sy791yqk0h90x2ym09asvpf2b"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-click" ,python-click)
+ ("python-cookiecutter" ,python-cookiecutter)
+ ("jupyter" ,jupyter)
+ ("python-networkx" ,python-networkx)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-tornado" ,python-tornado)
+ ("python-tqdm" ,python-tqdm)))
+ (home-page "https://github.com/projectmesa/mesa")
+ (synopsis
+ "Agent-based modeling (ABM) in Python 3+")
+ (description
+ "Mesa is an agent-based modeling framework in Python. It contains core
+components to implement spatial models, schedule agents and visualize model
+runs")
+ (license license:asl2.0)))
+
(define-public python-pympler
(package
(name "python-pympler")
From: Calvin Pritchard <calvin.pritchard@asu.edu> * gnu/packages/python-xyz.scm (python-mesa). New variables. --- gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++ 1 file changed, 30 insertions(+)