diff mbox series

[bug#35455] gnu: Add python-django-extensions.

Message ID 20190427163207.22869-1-smbaines8@gmail.com
State Accepted
Headers show
Series [bug#35455] gnu: Add python-django-extensions. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Sam April 27, 2019, 4:32 p.m. UTC
* gnu/packages/django.scm (python-django-extensions): New variable.
---
 gnu/packages/django.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Ludovic Courtès May 3, 2019, 3:47 p.m. UTC | #1
Sam <smbaines8@gmail.com> skribis:

> * gnu/packages/django.scm (python-django-extensions): New variable.

I added a copyright line for you in this file and committed.

> +    (arguments
> +     '(#:tests? #f)) ;TODO collected 378 items / 3 errors / 1 skipped

Could you investigate what these failures are about?  It could be that
the tests try to access the network, which won’t work in the isolated
build environment.  In that case, we’d just skip the faulty tests.

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 8ea9dca16a..3999e60198 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -25,6 +25,7 @@ 
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
@@ -119,6 +120,46 @@  to the @dfn{don't repeat yourself} (DRY) principle.")
          ;; required.
          ,@(package-native-inputs base))))))
 
+(define-public python-django-extensions
+  (package
+    (name "python-django-extensions")
+    (version "2.1.6")
+    (source
+     (origin
+       (method git-fetch)
+       ;; Fetch from the git repository, so that the tests can be run.
+       (uri (git-reference
+             (url "https://github.com/django-extensions/django-extensions.git")
+             (commit version)))
+       (file-name (string-append name "-" version))
+       (sha256
+        (base32
+         "0p4qrdinrv6indczlc8dcnm528i5fzmcn9xk1ja7ycfkyk5x6j5w"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f)) ;TODO collected 378 items / 3 errors / 1 skipped
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-vobject" ,python-vobject)
+       ("python-werkzeug" ,python-werkzeug)
+       ("python-dateutil" ,python-dateutil)
+       ("python-django" ,python-django)))
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-factory-boy" ,python-factory-boy)
+       ("python-tox" ,python-tox)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-django" ,python-pytest-django)
+       ("python-shortuuid" , python-shortuuid)))
+    (home-page
+     "https://github.com/django-extensions/django-extensions")
+    (synopsis "Custom management extensions for Django")
+    (description
+     "Django-extensions extends Django providing, for example, management
+commands, additional database fields and admin extensions.")
+    (license license:expat)))
+
 (define-public python-django-simple-math-captcha
   (package
     (name "python-django-simple-math-captcha")