diff mbox series

[bug#35412,1/2] gnu: rpm: Use python3 instead of python2.

Message ID 20190424100321.19312-1-jonathan.brielmaier@web.de
State Accepted
Headers show
Series [bug#35412,1/2] gnu: rpm: Use python3 instead of python2. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Jonathan Brielmaier April 24, 2019, 10:03 a.m. UTC
osc depends on python-rpm and requires python3 now.

* gnu/packages/package-management.scm (rpm)[inputs]: Use python instead
of python-2.
---
 gnu/packages/package-management.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--
2.21.0

Comments

Arun Isaac May 11, 2019, 8:45 a.m. UTC | #1
Thanks! I pushed your patches with a few modifications, of which the two
most notable are:

- I updated rpm to 4.14.2.1.
- GitHub autogenerated source tarballs are unstable (their hashes
change). So, I made osc use git-fetch instead of url-fetch.
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 6708a761eb..f3b592b9e9 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -518,7 +518,7 @@  symlinks to the files in a common directory such as /usr/local.")
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("python" ,python-2)
+     `(("python" ,python)
        ("xz" ,xz)
        ("bdb" ,bdb)
        ("popt" ,popt)