[bug#35288,1/3] gnu: Add dumb.

Message ID 20190415135134.31839-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#35288,1/3] gnu: Add dumb. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Kei Kebreau April 15, 2019, 1:51 p.m. UTC
* gnu/packages/music.scm (dumb): New variable.
---
 gnu/packages/music.scm | 65 +++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 64 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès April 18, 2019, 3:41 p.m. UTC | #1
Hello,

Kei Kebreau <kkebreau@posteo.net> skribis:

> * gnu/packages/music.scm (dumb): New variable.

[...]

> +    (home-page "https://github.com/kode54/dumb")
> +    (synopsis "Module audio renderer library")
> +    (description
> +     "DUMB is a tracker library with support for IT, XM, S3M and MOD files.  It
> +targets maximum accuracy to the original formats, with low-pass resonant filters
> +for the IT files, accurate timing and pitching, and three resampling quality
> +settings (aliasing, linear interpolation and cubic interpolation).")
> +    (license (license:fsf-free "file://LICENSE"))))

This looks good, but the license deserves close reading (which I haven’t
done).  What’s your interpretation of it?  It would be nice to put a
comment above to summarize our findings.

> +(define-public vcvrack
> +  (package
> +    (name "vcvrack")
> +    (version "0.6.2b")

What’s this doin’ here?  :-)

Thanks,
Ludo’.
Kei Kebreau April 20, 2019, 8:37 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hello,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/music.scm (dumb): New variable.
>
> [...]
>
>> +    (home-page "https://github.com/kode54/dumb")
>> +    (synopsis "Module audio renderer library")
>> +    (description
>> + "DUMB is a tracker library with support for IT, XM, S3M and MOD
>> files.  It
>> +targets maximum accuracy to the original formats, with low-pass
>> resonant filters
>> +for the IT files, accurate timing and pitching, and three resampling quality
>> +settings (aliasing, linear interpolation and cubic interpolation).")
>> +    (license (license:fsf-free "file://LICENSE"))))
>
> This looks good, but the license deserves close reading (which I haven’t
> done).  What’s your interpretation of it?  It would be nice to put a
> comment above to summarize our findings.
>

I've added the comment below in the patch summarizing my interpretation
of the DUMB license:

;; The DUMB license is a bit peculiar.
;; Clause 8 states that clauses 4, 5 and 6 are null and void, leaving only
;; the first three clauses for genuine consideration.
;; Clauses 1, 2 and 3 are analogous to clauses 1, 2 and 3 of the zlib
;; license, a known free software license.
;; Therefore, the DUMB license may be considered a free software license.

What do you think?

>> +(define-public vcvrack
>> +  (package
>> +    (name "vcvrack")
>> +    (version "0.6.2b")
>
> What’s this doin’ here?  :-)
>

Very basic packaging work on some other software, whoops!

> Thanks,
> Ludo’.
Ludovic Courtès April 21, 2019, 12:49 p.m. UTC | #3
Hello Kei,

Kei Kebreau <kkebreau@posteo.net> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hello,
>>
>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>
>>> * gnu/packages/music.scm (dumb): New variable.
>>
>> [...]
>>
>>> +    (home-page "https://github.com/kode54/dumb")
>>> +    (synopsis "Module audio renderer library")
>>> +    (description
>>> + "DUMB is a tracker library with support for IT, XM, S3M and MOD
>>> files.  It
>>> +targets maximum accuracy to the original formats, with low-pass
>>> resonant filters
>>> +for the IT files, accurate timing and pitching, and three resampling quality
>>> +settings (aliasing, linear interpolation and cubic interpolation).")
>>> +    (license (license:fsf-free "file://LICENSE"))))
>>
>> This looks good, but the license deserves close reading (which I haven’t
>> done).  What’s your interpretation of it?  It would be nice to put a
>> comment above to summarize our findings.
>>
>
> I've added the comment below in the patch summarizing my interpretation
> of the DUMB license:
>
> ;; The DUMB license is a bit peculiar.
> ;; Clause 8 states that clauses 4, 5 and 6 are null and void, leaving only
> ;; the first three clauses for genuine consideration.
> ;; Clauses 1, 2 and 3 are analogous to clauses 1, 2 and 3 of the zlib
> ;; license, a known free software license.
> ;; Therefore, the DUMB license may be considered a free software license.
>
> What do you think?

Sounds good!  (It’s available in Debian too, which is a good sign:
<https://packages.debian.org/sid/libdumb1>.)

>>> +(define-public vcvrack
>>> +  (package
>>> +    (name "vcvrack")
>>> +    (version "0.6.2b")
>>
>> What’s this doin’ here?  :-)
>>
>
> Very basic packaging work on some other software, whoops!

Heheh.  :-)

OK with these changes!

Thank you,
Ludo’.
Kei Kebreau April 21, 2019, 2:47 p.m. UTC | #4
Ludovic Courtès <ludo@gnu.org> writes:

> Hello Kei,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>> Hello,
>>>
>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>
>>>> * gnu/packages/music.scm (dumb): New variable.
>>>
>>> [...]
>>>
>>>> +    (home-page "https://github.com/kode54/dumb")
>>>> +    (synopsis "Module audio renderer library")
>>>> +    (description
>>>> + "DUMB is a tracker library with support for IT, XM, S3M and MOD
>>>> files.  It
>>>> +targets maximum accuracy to the original formats, with low-pass
>>>> resonant filters
>>>> +for the IT files, accurate timing and pitching, and three
>>>> resampling quality
>>>> +settings (aliasing, linear interpolation and cubic interpolation).")
>>>> +    (license (license:fsf-free "file://LICENSE"))))
>>>
>>> This looks good, but the license deserves close reading (which I haven’t
>>> done).  What’s your interpretation of it?  It would be nice to put a
>>> comment above to summarize our findings.
>>>
>>
>> I've added the comment below in the patch summarizing my interpretation
>> of the DUMB license:
>>
>> ;; The DUMB license is a bit peculiar.
>> ;; Clause 8 states that clauses 4, 5 and 6 are null and void, leaving only
>> ;; the first three clauses for genuine consideration.
>> ;; Clauses 1, 2 and 3 are analogous to clauses 1, 2 and 3 of the zlib
>> ;; license, a known free software license.
>> ;; Therefore, the DUMB license may be considered a free software license.
>>
>> What do you think?
>
> Sounds good!  (It’s available in Debian too, which is a good sign:
> <https://packages.debian.org/sid/libdumb1>.)
>
>>>> +(define-public vcvrack
>>>> +  (package
>>>> +    (name "vcvrack")
>>>> +    (version "0.6.2b")
>>>
>>> What’s this doin’ here?  :-)
>>>
>>
>> Very basic packaging work on some other software, whoops!
>
> Heheh.  :-)
>
> OK with these changes!
>
> Thank you,
> Ludo’.

Pushed to master, thanks again!

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 10a23c919f..522bad2528 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5,7 +5,7 @@ 
 ;;; Copyright © 2016 Al McElrath <hello@yrns.org>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2017 ng0 <ng0@n0.is>
@@ -81,6 +81,7 @@ 
   #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages game-development)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gettext)
@@ -446,6 +447,34 @@  background while you work.")
     (home-page "http://www.denemo.org")
     (license license:gpl3+)))
 
+(define-public dumb
+  (package
+    (name "dumb")
+    (version "2.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/kode54/dumb.git")
+             (commit version)))
+       (sha256
+        (base32 "1cnq6rb14d4yllr0yi32p9jmcig8avs3f43bvdjrx4r1mpawspi6"))
+       (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f ; no check target
+       #:configure-flags
+       (list "-DBUILD_SHARED_LIBS=ON"
+             "-DBUILD_EXAMPLES=OFF")))
+    (home-page "https://github.com/kode54/dumb")
+    (synopsis "Module audio renderer library")
+    (description
+     "DUMB is a tracker library with support for IT, XM, S3M and MOD files.  It
+targets maximum accuracy to the original formats, with low-pass resonant filters
+for the IT files, accurate timing and pitching, and three resampling quality
+settings (aliasing, linear interpolation and cubic interpolation).")
+    (license (license:fsf-free "file://LICENSE"))))
+
 (define-public hydrogen
   (package
     (name "hydrogen")
@@ -1061,6 +1090,40 @@  be used alone or in concert with Non Mixer and Non Sequencer to form a
 complete studio.")
     (license license:gpl2+)))
 
+(define-public vcvrack
+  (package
+    (name "vcvrack")
+    (version "0.6.2b")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/VCVRack/Rack.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0mn33aiafvqvds4hf9hywsr6f6y8y25g9vnjksf3cavxvnszy47y"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:make-flags '("CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)))) ; no configure phase
+    (inputs
+     `(("curl" ,curl)
+       ("glew" ,glew)
+       ("jansson" ,jansson)
+       ("libzip" ,libzip)
+       ("rtmidi" ,rtmidi)
+       ("speexdsp" ,speexdsp)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://vcvrack.com/")
+    (synopsis "Virtual modular synthesizer")
+    (description
+     "VCV Rack is a virtual modular synthesizer.")
+    (license license:bsd-3)))
+
 (define-public solfege
   (package
     (name "solfege")