[bug#35255] gnu: Add go-github-com-gokyle-twofactor.

Message ID 20190413100731.4720-1-pkill9@runbox.com
State Accepted
Headers show
Series [bug#35255] gnu: Add go-github-com-gokyle-twofactor. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

pkill9 April 13, 2019, 10:07 a.m. UTC
* gnu/packages/golang.scm (go-github-com-gokyle-twofactor): New variable.
---
This patch adds the first of four Golang packages required for building the browserpass binary (Used by the browserpass chromium extension to communicate with 'pass').

The license is declared MIT here: https://raw.githubusercontent.com/gokyle/twofactor/master/LICENSE

 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Leo Famulari April 13, 2019, 5:46 p.m. UTC | #1
On Sat, Apr 13, 2019 at 11:07:31AM +0100, Pkill -9 wrote:
> +(define-public go-github-com-gokyle-twofactor

Thank you!

> +    (synopsis "Two-factor authentication")
> +    (description "Golang package for providing two-factor authentication.")

Can you make the description a complete sentence, and possibly adding
some more details about the package?
Sharlatan Hellseher Jan. 27, 2024, 12:37 p.m. UTC | #2
Hi,

The upstream project looks like abandoned for 4 years already, and I
can't see references in patch tracker where it may be used.

Thanks,
Oleg
Sharlatan Hellseher Feb. 8, 2024, 6:13 p.m. UTC | #3
Hi,

The upstream project is abandon and there is no active forks.

This patch will be no applied.

Thanks,
Oleg

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0b44bd3..e1ae77d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright @ 2018, 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
+;;; Copyright @ 2019 Pkill -9 <pkill9@runbox.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3274,3 +3275,25 @@  test.
 All locks are implemented with read-write mutexes.  To use them like a regular
 mutex, simply ignore the RLock/RUnlock functions.")
       (license license:unlicense))))
+
+(define-public go-github-com-gokyle-twofactor
+  (package
+    (name "go-github-com-gokyle-twofactor")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gokyle/twofactor.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0fhbw6cyq054w4frfvbgmffijg0bd1shvawm3ddl4cf1l12x1qxh"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/gokyle/twofactor"))
+    (home-page "https://github.com/gokyle/twofactor")
+    (synopsis "Two-factor authentication")
+    (description "Golang package for providing two-factor authentication.")
+    (license license:expat)))