[bug#35223] gnu: linux-libre: Set DEVPTS_MULTIPLE_INSTANCES only where needed.

Message ID 20190410231936.15275-1-somebody@not-sent-or-endorsed-by.tobias.gr
State Accepted
Headers show
Series [bug#35223] gnu: linux-libre: Set DEVPTS_MULTIPLE_INSTANCES only where needed. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Tobias Geerinckx-Rice April 10, 2019, 11:19 p.m. UTC
From: Tobias Geerinckx-Rice <me@tobias.gr>

* gnu/packages/linux.scm (%default-extra-linux-options): Move obsolete
CONFIG_DEVPTS_MULTIPLE_INSTANCES option…
(linux-libre-4.4): …here.
---
 gnu/packages/linux.scm | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès April 11, 2019, 11:37 a.m. UTC | #1
Hello,

Tobias Geerinckx-Rice <somebody@not-sent-or-endorsed-by.tobias.gr>
skribis:

> From: Tobias Geerinckx-Rice <me@tobias.gr>
>
> * gnu/packages/linux.scm (%default-extra-linux-options): Move obsolete
> CONFIG_DEVPTS_MULTIPLE_INSTANCES option…
> (linux-libre-4.4): …here.

So “make config” was emitting a warning on kernels > 4.7, right?

As long as things still work after this patch, go for it!

Thanks,
Ludo’.
Tobias Geerinckx-Rice April 11, 2019, 12:43 p.m. UTC | #2
Ludo',

Ludovic Courtès wrote:
> Tobias Geerinckx-Rice 
> <somebody@not-sent-or-endorsed-by.tobias.gr>
> skribis:
>
>> From: Tobias Geerinckx-Rice <me@tobias.gr>
>>
>> * gnu/packages/linux.scm (%default-extra-linux-options): Move 
>> obsolete
>> CONFIG_DEVPTS_MULTIPLE_INSTANCES option…
>> (linux-libre-4.4): …here.
>
> So “make config” was emitting a warning on kernels > 4.7, right?

Oh, maybe; no idea.

I was tweaking my old kustom (pf-)kernel to be Guix-ready and 
noticed that this option was missing.

> As long as things still work after this patch, go for it!

AFAICT: yes.

Thanks!

T G-R
Tobias Geerinckx-Rice April 14, 2019, 6:20 p.m. UTC | #3
Tobias Geerinckx-Rice wrote:
>>> * gnu/packages/linux.scm (%default-extra-linux-options): Move
>>> obsolete
>>> CONFIG_DEVPTS_MULTIPLE_INSTANCES option…
>>> (linux-libre-4.4): …here.

[…]

>> As long as things still work after this patch, go for it!
>
> AFAICT: yes.

Pushed as 8b4e76249a4d1b4af5da6a8b07f4fb3c92234c07.

Kind regards,

T G-R

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 710fd2d299..c80cee6422 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -264,9 +264,7 @@  for ARCH and optionally VARIANT, or #f if there is no such configuration."
     (search-auxiliary-file file)))
 
 (define %default-extra-linux-options
-  `(;; https://lists.gnu.org/archive/html/guix-devel/2014-04/msg00039.html
-    ("CONFIG_DEVPTS_MULTIPLE_INSTANCES" . #t)
-    ;; Modules required for initrd:
+  `(;; Modules required for initrd:
     ("CONFIG_NET_9P" . m)
     ("CONFIG_NET_9P_VIRTIO" . m)
     ("CONFIG_VIRTIO_BLK" . m)
@@ -471,7 +469,13 @@  It has been modified to remove all non-free binary blobs.")
   (make-linux-libre "4.4.178"
                     "1lgsd760md6b32qb5ng3anfq1n754a9d0c4xnf2mjxkimncb1jpp"
                     '("x86_64-linux" "i686-linux")
-                    #:configuration-file kernel-config))
+                    #:configuration-file kernel-config
+                    #:extra-options
+                    (append
+                     `(;; https://lists.gnu.org/archive/html/guix-devel/2014-04/msg00039.html
+                       ;; This option was removed upstream in version 4.7.
+                       ("CONFIG_DEVPTS_MULTIPLE_INSTANCES" . #t))
+                     %default-extra-linux-options)))
 
 (define-public linux-libre-arm-generic
   (make-linux-libre %linux-libre-version