[bug#35207,2/3] gnu: Add ocaml4.02-gsl.

Message ID 20190409131330.12089-2-rekado@elephly.net
State Accepted
Headers show
Series [bug#35207,1/3] gnu: Add ocaml4.02-mcl. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ricardo Wurmus April 9, 2019, 1:13 p.m. UTC
* gnu/packages/ocaml.scm (ocaml4.02-gsl): New variable.
---
 gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7bebf3921b..bf5d39db6c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4824,6 +4824,28 @@  Atom.")
 the OCaml language.")
     (license license:gpl3+)))
 
+;; This is the last version that can be built with without ocaml-base, which
+;; cannot be built with OCaml 4.02.
+(define-public ocaml4.02-gsl
+  (package
+    (inherit (package-with-ocaml4.02 ocaml-gsl))
+    (version "1.19.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/mmottl/gsl-ocaml"
+                                  "/releases/download/v"
+                                  version "/gsl-ocaml-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"))))
+    (build-system ocaml-build-system)
+    (inputs
+     `(("gsl" ,gsl)))
+    (arguments
+     `(#:ocaml ,ocaml-4.02
+       #:findlib ,ocaml4.02-findlib))
+    (propagated-inputs '())))
+
 (define-public cubicle
   (package
     (name "cubicle")