[bug#35111] gnu: make-linux-libre: Install "Module.symvers".

Message ID 20190403001349.11373-1-dannym@scratchpost.org
State Accepted
Headers show
Series [bug#35111] gnu: make-linux-libre: Install "Module.symvers". | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Danny Milosavljevic April 3, 2019, 12:13 a.m. UTC
* gnu/packages/linux.scm (make-linux-libre): Install "Module.symvers".
---
 gnu/packages/linux.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès April 11, 2019, 10:51 a.m. UTC | #1
Danny Milosavljevic <dannym@scratchpost.org> skribis:

> * gnu/packages/linux.scm (make-linux-libre): Install "Module.symvers".

LGTM!

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a2adb9b13d..bd7afccc52 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -392,7 +392,7 @@  for ARCH and optionally VARIANT, or #f if there is no such configuration."
                     (kmod   (assoc-ref (or native-inputs inputs) "kmod")))
                ;; Install kernel image, kernel configuration and link map.
                (for-each (lambda (file) (install-file file out))
-                         (find-files "." "^(\\.config|bzImage|zImage|Image|vmlinuz|System\\.map)$"))
+                         (find-files "." "^(\\.config|bzImage|zImage|Image|vmlinuz|System\\.map|Module\\.symvers)$"))
                ;; Install device tree files
                (unless (null? (find-files "." "\\.dtb$"))
                  (mkdir-p dtbdir)