[bug#35110,2/3] gnu: Add vhba-module-linux-libre.

Message ID 20190402192855.5314-2-dannym@scratchpost.org
State Accepted
Headers show
Series Add support for loadable modules. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Danny Milosavljevic April 2, 2019, 7:28 p.m. UTC
From: Pierre Neidhardt <mail@ambrevar.xyz>

* gnu/packages/linux.scm (vhba-module): New variable.
(vhba-module-linux-libre): New variable.  Export it.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
---
 gnu/packages/linux.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Pierre Neidhardt April 2, 2019, 9:51 p.m. UTC | #1
Thanks for looking into this!

Danny Milosavljevic <dannym@scratchpost.org> writes:

> +(define-public vhba-module-linux-libre
> +  (make-linux-module linux-libre vhba-module))

What is make-linux-module?  I cannot find it on master :p
Danny Milosavljevic April 2, 2019, 10:36 p.m. UTC | #2
See PATCH 1/3, Message ID <20190402192855.5314-1-dannym@scratchpost.org>
Pierre Neidhardt April 3, 2019, 6:48 a.m. UTC | #3
Brilliant!  Thank you so much for this!

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 55a314258f..a2adb9b13d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -495,6 +495,34 @@  It has been modified to remove all non-free binary blobs.")
                     #:patches %linux-libre-5.0-patches
                     #:configuration-file kernel-config))
 
+(define vhba-module
+  (package
+    (name "vhba-module")
+    (version "20170610")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://downloads.sourceforge.net/cdemu/vhba-module-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "1v6r0bgx0a65vlh36b1l2965xybngbpga6rp54k4z74xk0zwjw3r"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; TODO: No tests?
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (home-page "https://cdemu.sourceforge.io/")
+    (synopsis "Kernel module that emulates SCSI devices")
+    (description "VHBA module provides a Virtual (SCSI) HBA, which is the link
+between the CDemu userspace daemon and linux kernel.")
+    (license license:gpl2+)))
+
+(define-public vhba-module-linux-libre
+  (make-linux-module linux-libre vhba-module))
+
 (define %linux-libre-4.19-version "4.19.32")
 (define %linux-libre-4.19-hash "19bryl8nmnnnrfh91pc8q9yiayh5ca2nb6b32qyx6riahc5dy0i9")