[bug#34931,4/5] gnu: Add python-mygpoclient.

Message ID 20190321002204.25294-4-pierre.langlois@gmx.com
State Accepted
Headers show
Series [bug#34931,1/5] gnu: libmygpo-qt: Move to new 'gpodder.scm' file. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch fail Apply failed

Commit Message

Pierre Langlois March 21, 2019, 12:22 a.m. UTC
* gnu/packages/podcast.scm (python-mygpoclient, python2-mygpoclient): New
variables.
---
 gnu/packages/gpodder.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

--
2.21.0

Comments

swedebugia June 27, 2019, 7:38 p.m. UTC | #1
On 2019-03-21 01:22, Pierre Langlois wrote:
> * gnu/packages/podcast.scm (python-mygpoclient, python2-mygpoclient): New
> variables.
> ---
>   gnu/packages/gpodder.scm | 22 ++++++++++++++++++++++
>   1 file changed, 22 insertions(+)
> 
> diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
> index 5b872908a5..654d6b2f96 100644
> --- a/gnu/packages/gpodder.scm
> +++ b/gnu/packages/gpodder.scm
> @@ -57,6 +57,28 @@
>   and track podcasts.")
>       (license license:lgpl2.1+)))
> 
> +(define-public python-mygpoclient
> +  (package
> +    (name "python-mygpoclient")
> +    (version "1.8")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "mygpoclient" version))
> +       (sha256
> +        (base32
> +         "1fi5x6k1mngr0iviw2s4n1f3y2x7pwqy5ivkcrjdprzvwr37f0mh"))))
> +    (build-system python-build-system)
> +    (native-inputs
> +     `(("python-minimock" ,python-minimock)))
> +    (home-page "https://mygpoclient.readthedocs.io")
> +    (synopsis "Python library for the gPodder web service")
> +    (description "@code{mygpoclient} provides an easy and structured way to
> +access the @url{https://gpodder.net} web services.  In addition to
> +subscription list synchronization and storage, the API supports uploading and
> +downloading episode status changes.")
> +    (license license:gpl3)))

According to the files it is gpl3+

Apart from that LGTM.

Thanks!
Pierre Langlois June 27, 2019, 10:33 p.m. UTC | #2
Hello!

swedebugia writes:

> On 2019-03-21 01:22, Pierre Langlois wrote:
>> * gnu/packages/podcast.scm (python-mygpoclient, python2-mygpoclient): New
>> variables.
>> ---
>>   gnu/packages/gpodder.scm | 22 ++++++++++++++++++++++
>>   1 file changed, 22 insertions(+)
>>
>> diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
>> index 5b872908a5..654d6b2f96 100644
>> --- a/gnu/packages/gpodder.scm
>> +++ b/gnu/packages/gpodder.scm
>> @@ -57,6 +57,28 @@
>>   and track podcasts.")
>>       (license license:lgpl2.1+)))
>>
>> +(define-public python-mygpoclient
>> +  (package
>> +    (name "python-mygpoclient")
>> +    (version "1.8")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (pypi-uri "mygpoclient" version))
>> +       (sha256
>> +        (base32
>> +         "1fi5x6k1mngr0iviw2s4n1f3y2x7pwqy5ivkcrjdprzvwr37f0mh"))))
>> +    (build-system python-build-system)
>> +    (native-inputs
>> +     `(("python-minimock" ,python-minimock)))
>> +    (home-page "https://mygpoclient.readthedocs.io")
>> +    (synopsis "Python library for the gPodder web service")
>> +    (description "@code{mygpoclient} provides an easy and structured way to
>> +access the @url{https://gpodder.net} web services.  In addition to
>> +subscription list synchronization and storage, the API supports uploading and
>> +downloading episode status changes.")
>> +    (license license:gpl3)))
>
> According to the files it is gpl3+

Oh, whoops I missed that! I'll submit an update by the end of the week!

Thanks!
Pierre Langlois June 28, 2019, 6:11 a.m. UTC | #3
Pierre Langlois writes:

> Hello!
>
> swedebugia writes:
>
>> On 2019-03-21 01:22, Pierre Langlois wrote:
>>> * gnu/packages/podcast.scm (python-mygpoclient, python2-mygpoclient): New
>>> variables.
>>> ---
>>>   gnu/packages/gpodder.scm | 22 ++++++++++++++++++++++
>>>   1 file changed, 22 insertions(+)
>>>
>>> diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
>>> index 5b872908a5..654d6b2f96 100644
>>> --- a/gnu/packages/gpodder.scm
>>> +++ b/gnu/packages/gpodder.scm
>>> @@ -57,6 +57,28 @@
>>>   and track podcasts.")
>>>       (license license:lgpl2.1+)))
>>>
>>> +(define-public python-mygpoclient
>>> +  (package
>>> +    (name "python-mygpoclient")
>>> +    (version "1.8")
>>> +    (source
>>> +     (origin
>>> +       (method url-fetch)
>>> +       (uri (pypi-uri "mygpoclient" version))
>>> +       (sha256
>>> +        (base32
>>> +         "1fi5x6k1mngr0iviw2s4n1f3y2x7pwqy5ivkcrjdprzvwr37f0mh"))))
>>> +    (build-system python-build-system)
>>> +    (native-inputs
>>> +     `(("python-minimock" ,python-minimock)))
>>> +    (home-page "https://mygpoclient.readthedocs.io")
>>> +    (synopsis "Python library for the gPodder web service")
>>> +    (description "@code{mygpoclient} provides an easy and structured way to
>>> +access the @url{https://gpodder.net} web services.  In addition to
>>> +subscription list synchronization and storage, the API supports uploading and
>>> +downloading episode status changes.")
>>> +    (license license:gpl3)))
>>
>> According to the files it is gpl3+
>
> Oh, whoops I missed that! I'll submit an update by the end of the week!

It looks like this was fixed before committing (see b58ab1598fc615f3f11ad7b439e61e0616117e2c).

Ludo must have either pointed it out or fixed it for me, I don't
remember :-).

Thanks,
Pierre

Patch

diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 5b872908a5..654d6b2f96 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -57,6 +57,28 @@ 
 and track podcasts.")
     (license license:lgpl2.1+)))

+(define-public python-mygpoclient
+  (package
+    (name "python-mygpoclient")
+    (version "1.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mygpoclient" version))
+       (sha256
+        (base32
+         "1fi5x6k1mngr0iviw2s4n1f3y2x7pwqy5ivkcrjdprzvwr37f0mh"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-minimock" ,python-minimock)))
+    (home-page "https://mygpoclient.readthedocs.io")
+    (synopsis "Python library for the gPodder web service")
+    (description "@code{mygpoclient} provides an easy and structured way to
+access the @url{https://gpodder.net} web services.  In addition to
+subscription list synchronization and storage, the API supports uploading and
+downloading episode status changes.")
+    (license license:gpl3)))
+
 (define-public python-podcastparser
   (package
     (name "python-podcastparser")