[bug#34912] gnu: Add xl2tpd.

Message ID 20190319073410.4117-1-sleep_walker@gnu.org
State Accepted
Headers show
Series [bug#34912] gnu: Add xl2tpd. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Tomáš Čech March 19, 2019, 7:34 a.m. UTC
* gnu/packages/vpn.scm (xl2tpd): New variable.
---
 gnu/packages/vpn.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 6475a738d..88fd9e142 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -35,6 +35,7 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
+  #:use-module (gnu packages admin)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages autotools)
@@ -517,3 +518,29 @@  retrieving configuration of WireGuard network tunnel interfaces, and a patch
 that can be applied to a Linux kernel source tree in order to build it with
 WireGuard support.")
     (license license:gpl2)))
+
+(define-public xl2tpd
+  (package
+    (name "xl2tpd")
+    (version "1.3.13")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/xelerance/xl2tpd/archive/v"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0xycsxwslvwxpiw994s8prp7riybxs1kcax4ci9jh3jd65zwcsp7"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list (string-append "DESTDIR=" %output)
+                          "CC=gcc")
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure))
+       #:tests? #f)) ;; no tests provided
+    (inputs `(("libpcap" ,libpcap)))
+    (home-page "https://www.xelerance.com/software/xl2tpd/")
+    (synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
+    (description
+     "xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
+L2TP allows you to tunnel PPP over UDP.")
+    (license license:gpl2)))