[bug#34868] gnu: coq-flocq: remove unnecessary return values

Message ID 20190315121624.3818-1-dfrumin@cs.ru.nl
State Accepted
Commit 718d358a7297c6f101ca320818ce2206a3ad893f
Headers show
Series [bug#34868] gnu: coq-flocq: remove unnecessary return values | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Dan Frumin March 15, 2019, 12:16 p.m. UTC
---
 gnu/packages/coq.scm | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)

Comments

Ludovic Courtès March 19, 2019, 10:23 a.m. UTC | #1
Hi,

Dan Frumin <dfrumin@cs.ru.nl> skribis:

> ---
>  gnu/packages/coq.scm | 9 +++------
>  1 file changed, 3 insertions(+), 6 deletions(-)

I added a commit log and applied.  Thank you!

Ludo’.

Patch

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 83f5cd29af..bdf1576400 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -211,18 +211,15 @@  provers.")
              #t))
          (replace 'build
            (lambda _
-             (invoke "./remake")
-             #t))
+             (invoke "./remake")))
          (replace 'check
            (lambda _
-             (invoke "./remake" "check")
-             #t))
+             (invoke "./remake" "check")))
              ;; TODO: requires coq-gappa and coq-interval.
              ;(invoke "./remake" "check-more")
          (replace 'install
            (lambda _
-             (invoke "./remake" "install")
-             #t)))))
+             (invoke "./remake" "install"))))))
     (home-page "http://flocq.gforge.inria.fr/")
     (synopsis "Floating-point formalization for the Coq system")
     (description "Flocq (Floats for Coq) is a floating-point formalization for