[bug#34779,v2] gnu: neovim: Partially fix #34616.

Message ID 20190307093512.23795-1-boskovits@gmail.com
State Accepted
Commit 0a10abf73e7bb1d5f751229c709903a0f66574d2
Headers show
Series [bug#34779,v2] gnu: neovim: Partially fix #34616. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Gábor Boskovits March 7, 2019, 9:35 a.m. UTC
* gnu/packages/vim.scm (neovim)[arguments](phases): Add phase 'patch-tic.

This fixes a segmentation fault in neovim, where an error return value
is passed in as a pointer.
---
 gnu/packages/vim.scm | 6 ++++++
 1 file changed, 6 insertions(+)

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 5e1e9b852c..a6f4395f53 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -693,6 +693,12 @@  are detected, the user is notified.")))
        #:configure-flags '("-DPREFER_LUA:BOOL=YES")
        #:phases
        (modify-phases %standard-phases
+         ;; TODO: remove 'patch-tic on update
+         ;; see: https://github.com/neovim/neovim/issues/9687
+         (add-after 'unpack 'patch-tic
+           (lambda _
+             (substitute* "src/nvim/tui/tui.c"
+               (("value != NULL") "value != NULL && value != (char *)-1"))))
          (add-after 'unpack 'set-lua-paths
            (lambda* (#:key inputs #:allow-other-keys)
              (let* ((lua-version "5.2")