[bug#34755] gnu: Remove duplicate r-dnacopy package.

Message ID 20190305081408.17814-1-mail@cbaines.net
State Superseded
Headers show
Series [bug#34755] gnu: Remove duplicate r-dnacopy package. | expand

Checks

Context Check Description
cbaines/comparison success View comparison
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines March 5, 2019, 8:14 a.m. UTC
This package definition duplicates the earlier definition in the (gnu packages
bioinformatics) module.

This reverts commit c18dccffa20bf09826758210d457d1df477f959c.

* gnu/packages/bioconductor.scm (r-dnacopy): Remove this variable.
---
 gnu/packages/bioconductor.scm | 23 -----------------------
 1 file changed, 23 deletions(-)

Comments

Ricardo Wurmus March 5, 2019, 9:25 a.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> This package definition duplicates the earlier definition in the (gnu packages
> bioinformatics) module.
>
> This reverts commit c18dccffa20bf09826758210d457d1df477f959c.
>
> * gnu/packages/bioconductor.scm (r-dnacopy): Remove this variable.

Thanks for noticing this.

I’d rather remove the packgae from (gnu packages bioinformatics).  I’ll
take care of this today.

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ae9d7070c3..dfd3de5901 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -27,7 +27,6 @@ 
   #:use-module (gnu packages bioinformatics)
   #:use-module (gnu packages cran)
   #:use-module (gnu packages compression)
-  #:use-module (gnu packages gcc)
   #:use-module (gnu packages graph)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages statistics)
@@ -1178,28 +1177,6 @@  Viewer (SAV) files, access data, and generate QC plots.")
 sequencing data.")
     (license license:gpl2+)))
 
-(define-public r-dnacopy
-  (package
-    (name "r-dnacopy")
-    (version "1.56.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "DNAcopy" version))
-       (sha256
-        (base32
-         "04cqdqxhva66xwh1s2vffi56b9fcrqd4slcrvqasj5lp2rkjli82"))))
-    (properties `((upstream-name . "DNAcopy")))
-    (build-system r-build-system)
-    (native-inputs `(("gfortran" ,gfortran)))
-    (home-page "https://bioconductor.org/packages/DNAcopy")
-    (synopsis "DNA copy number data analysis")
-    (description
-     "This package implements the @dfn{circular binary segmentation} (CBS)
-algorithm to segment DNA copy number data and identify genomic regions with
-abnormal copy number.")
-    (license license:gpl2+)))
-
 ;; This is a CRAN package, but it uncharacteristically depends on a
 ;; Bioconductor package.
 (define-public r-htscluster