[bug#34747] gnu: coq-coquelicot: Update to 3.0.2.

Message ID 20190304153602.7057-1-dfrumin@cs.ru.nl
State Accepted
Commit 3d03fed47fc9a9af784a026a8ac76418f609b639
Headers show
Series [bug#34747] gnu: coq-coquelicot: Update to 3.0.2. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Dan Frumin March 4, 2019, 3:36 p.m. UTC
---
 gnu/packages/coq.scm | 12 +++---------
 1 file changed, 3 insertions(+), 9 deletions(-)

Comments

Julien Lepiller March 4, 2019, 8:14 p.m. UTC | #1
Pushed as 3d03fed47fc9a9af784a026a8ac76418f609b639. Thank you!

Patch

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 5393d4273..83f5cd29a 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -327,14 +327,14 @@  part of the distribution.")
 (define-public coq-coquelicot
   (package
     (name "coq-coquelicot")
-    (version "3.0.1")
+    (version "3.0.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://gforge.inria.fr/frs/download.php/"
-                                  "file/37045/coquelicot-" version ".tar.gz"))
+                                  "file/37523/coquelicot-" version ".tar.gz"))
               (sha256
                (base32
-                "0hsyhsy2lwqxxx2r8xgi5csmirss42lp9bkb9yy35mnya0w78c8r"))))
+                "1biia7nfqf7vaqq5gmykl4rwjyvrcwss6r2jdf0in5pvp2rnrj2w"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("ocaml" ,ocaml)
@@ -348,12 +348,6 @@  part of the distribution.")
                             "/lib/coq/user-contrib/Coquelicot"))
        #:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'fix-coq8.8
-           (lambda _
-             ; appcontext has been removed from coq 8.8
-             (substitute* "theories/AutoDerive.v"
-               (("appcontext") "context"))
-             #t))
          (add-before 'configure 'fix-remake
            (lambda _
              (substitute* "remake.cpp"