[bug#34653] gnu: twitchy: Update to 3.4.

Message ID 20190225183854.32008-1-eisenmann@fn.de
State Accepted
Commit 04b6e9c5dffb0830338dda39d90cf7b2d165b3fc
Headers show
Series [bug#34653] gnu: twitchy: Update to 3.4. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Timo Eisenmann Feb. 25, 2019, 6:38 p.m. UTC
* gnu/packages/video.scm: (twitchy): Update to 3.4.
[arguments]: Add phase 'patch-paths' to substitute in the absolute path to
'streamlink'.
---
 gnu/packages/video.scm | 14 +++++++++++---
 1 file changed, 11 insertions(+), 3 deletions(-)

Comments

Leo Famulari Feb. 26, 2019, 2:34 a.m. UTC | #1
On Mon, Feb 25, 2019 at 07:38:54PM +0100, Timo Eisenmann wrote:
> * gnu/packages/video.scm: (twitchy): Update to 3.4.
> [arguments]: Add phase 'patch-paths' to substitute in the absolute path to
> 'streamlink'.

Thanks! Pushed as 04b6e9c5dffb0830338dda39d90cf7b2d165b3fc

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b0c875befe..52f151bd78 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -32,6 +32,7 @@ 
 ;;; Copyright © 2018 Mark Meyer <mark@ofosos.org>
 ;;; Copyright © 2018 Gábor Boskovit <boskovits@gmail.com>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Timo Eisenmann <eisenmann@fn.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1999,10 +2000,10 @@  from sites like Twitch.tv and pipes them into a video player of choice.")
   (deprecated-package "livestreamer" streamlink))
 
 (define-public twitchy
-  (let ((commit "0c0f925b9c7ff2aed4a3b0046561cb794143c398")) ;Fixes tests.
+  (let ((commit "9beb36d80b16662414129693e74fa3a2fd97554e")) ; 3.4 has no tag
     (package
       (name "twitchy")
-      (version (git-version "3.2" "1" commit))
+      (version (git-version "3.4" "1" commit))
       (source
        (origin
          (method git-fetch)
@@ -2012,11 +2013,18 @@  from sites like Twitch.tv and pipes them into a video player of choice.")
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "02aizvsr744sh8bdqvwwsmp2qpczlzn8fy76h5dyd3517n9nlcz9"))))
+           "0di03h1j9ipp2bbnxxlxz07v87icyg2hmnsr4s7184z5ql8kpzr7"))))
       (build-system python-build-system)
       (arguments
        '(#:phases
          (modify-phases %standard-phases
+           (add-after 'unpack 'patch-paths
+             (lambda* (#:key inputs #:allow-other-keys)
+               (substitute* "twitchy/twitchy_play.py"
+                 (("\"streamlink ")
+                  (string-append "\"" (assoc-ref inputs "streamlink")
+                                 "/bin/streamlink ")))
+               #t))
            (add-before 'check 'check-setup
              (lambda _
                (setenv "HOME" (getcwd)) ;Needs to write to ‘$HOME’.