[bug#34646] gnu: openssh: Add libedit support.

Message ID 20190225130846.7982-1-boskovits@gmail.com
State Accepted
Commit 618631f3683e7caf5b0336ce06abf62a25ce119b
Headers show
Series [bug#34646] gnu: openssh: Add libedit support. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Gábor Boskovits Feb. 25, 2019, 1:08 p.m. UTC
* gnu/packages/ssh.scm (openssh)[native-inputs]: Add pkg-config.
[inputs]: Add libedit.
[arguments](configure-flags): Add --with-libedit.
---
 gnu/packages/ssh.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)

Comments

Gábor Boskovits Feb. 25, 2019, 1:16 p.m. UTC | #1
Hello,

This is to enable sftp completion support.
The problem was noticed by tune on IRC.
Wdyt?

Best regards,
g_bor
Leo Famulari Feb. 26, 2019, 4:44 a.m. UTC | #2
On Mon, Feb 25, 2019 at 02:16:32PM +0100, Gábor Boskovits wrote:
> Hello,
> 
> This is to enable sftp completion support.
> The problem was noticed by tune on IRC.
> Wdyt?

Sounds good, I did some basic tests.  But can you try updating libedit
to the latest release before pushing?
Gábor Boskovits Feb. 26, 2019, 11:22 p.m. UTC | #3
Libedit updated in 1094f1216f21a52453b54b43ff88b856f4fac94d.
Patch pushed as 618631f3683e7caf5b0336ce06abf62a25ce119b.
Closing.

Thanks for the review.

Patch

diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 1928ea7634..968118ad19 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
 ;;; Copyright © 2018 Manuel Graf <graf@init.at>
+;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -39,6 +40,7 @@ 
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages groff)
   #:use-module (gnu packages guile)
+  #:use-module (gnu packages libedit)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages logging)
   #:use-module (gnu packages m4)
@@ -154,8 +156,10 @@  a server that supports the SSH-2 protocol.")
               (base32
                "1b8sy6v0b8v4ggmknwcqx3y1rjcpsll0f1f8f4vyv11x4ni3njvb"))))
    (build-system gnu-build-system)
-   (native-inputs `(("groff" ,groff)))
-   (inputs `(("openssl" ,openssl)
+   (native-inputs `(("groff" ,groff)
+                    ("pkg-config" ,pkg-config)))
+   (inputs `(("libedit" ,libedit)
+             ("openssl" ,openssl)
              ("pam" ,linux-pam)
              ("mit-krb5" ,mit-krb5)
              ("zlib" ,zlib)
@@ -175,6 +179,9 @@  a server that supports the SSH-2 protocol.")
                                           (assoc-ref %build-inputs "mit-krb5")
                                           "/bin")
 
+                          ;; libedit needed for sftp completion
+                          "--with-libedit"
+
                           ;; Enable PAM support in sshd.
                           "--with-pam")