[bug#34634,1/1] gnu: tryton: Add tryton 5.0.6.

Message ID 20190223140939.54371269@riseup.net
State Accepted
Headers show
Series [bug#34634,1/1] gnu: tryton: Add tryton 5.0.6. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Jovany Leandro G.C Feb. 23, 2019, 7:09 p.m. UTC
From 693d00d1df68ada3bb43cbaecdd2823976e87bd4 Mon Sep 17 00:00:00 2001
From: "Jovany Leandro G.C" <bit4bit@riseup.net>
Date: Sat, 23 Feb 2019 14:08:01 -0500
Subject: [PATCH 1/1] gnu: tryton: Add tryton 5.0.6.

* gnu/packages/tryton.scm (tryton-5): New variable.
---
 gnu/packages/tryton.scm | 42 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

   (name "python-trytond-country")

Comments

Ludovic Courtès March 11, 2019, 10:15 p.m. UTC | #1
Hi Jovany,

Your email client mangled the patch.  In the future could you send
patches as attachments or use ‘git send-email’?

"Jovany Leandro G.C" <bit4bit@riseup.net> skribis:

> From 693d00d1df68ada3bb43cbaecdd2823976e87bd4 Mon Sep 17 00:00:00 2001
> From: "Jovany Leandro G.C" <bit4bit@riseup.net>
> Date: Sat, 23 Feb 2019 14:08:01 -0500
> Subject: [PATCH 1/1] gnu: tryton: Add tryton 5.0.6.
>
> * gnu/packages/tryton.scm (tryton-5): New variable.

Do you think we should keep both version 4 and version 5?  Is it
generally useful today to have these two versions available?

> +(define-public tryton-5
> +  (package
> +    (name "tryton")
> +    (version "5.0.6")

Should it inherit from ‘tryton’?

> +    (arguments
> +     `(;;_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix
> will not be created.
> +       #:tests? #f

Could you try adding a phase before ‘check’ that spawns Xvfb?  There are
several examples of this.

> +    (license license:gpl3)))

Version 3 only, or version 3 “or any later version”?

Could you send an updated patch?

Thank you,
Ludo’.
Jovany Leandro G.C March 12, 2019, 9:58 p.m. UTC | #2
El Mon, 11 Mar 2019 23:15:39 +0100
Ludovic Courtès <ludo@gnu.org> escribió:
> Hi Jovany,
> 
> Your email client mangled the patch.  In the future could you send
> patches as attachments or use ‘git send-email’?
ok sorry, i will be more alert with this
> 
> "Jovany Leandro G.C" <bit4bit@riseup.net> skribis:
> 
> > From 693d00d1df68ada3bb43cbaecdd2823976e87bd4 Mon Sep 17 00:00:00
> > 2001 From: "Jovany Leandro G.C" <bit4bit@riseup.net>
> > Date: Sat, 23 Feb 2019 14:08:01 -0500
> > Subject: [PATCH 1/1] gnu: tryton: Add tryton 5.0.6.
> >
> > * gnu/packages/tryton.scm (tryton-5): New variable.  
> 
> Do you think we should keep both version 4 and version 5?  Is it
> generally useful today to have these two versions available?
> 
yeah it's very useful, tryton 4 and 5 both have updates, now 5 will be
LTS
> > +(define-public tryton-5
> > +  (package
> > +    (name "tryton")
> > +    (version "5.0.6")  
> 
> Should it inherit from ‘tryton’?
what it's the best path for this?
a guide please
> > +    (arguments
> > +     `(;;_XSERVTransmkdir: ERROR: euid !=
> > 0,directory /tmp/.X11-unix will not be created.
> > +       #:tests? #f  
> 
> Could you try adding a phase before ‘check’ that spawns Xvfb?  There
ok, i try before send the patch, and not work but will try again
> are several examples of this.
> 
> > +    (license license:gpl3)))  
> 
> Version 3 only, or version 3 “or any later version”?
> 
http://hg.tryton.org/tryton/file/5.0/LICENSE
yeah GPL-3+

> Could you send an updated patch?
> 
> Thank you,
> Ludo’.

yeah i will work on it.


thanks for you time and work
Ludovic Courtès March 13, 2019, 10:31 a.m. UTC | #3
Hello Jovany,

"Jovany Leandro G.C" <bit4bit@riseup.net> skribis:

> El Mon, 11 Mar 2019 23:15:39 +0100
> Ludovic Courtès <ludo@gnu.org> escribió:

[...]

>> "Jovany Leandro G.C" <bit4bit@riseup.net> skribis:
>> 
>> > From 693d00d1df68ada3bb43cbaecdd2823976e87bd4 Mon Sep 17 00:00:00
>> > 2001 From: "Jovany Leandro G.C" <bit4bit@riseup.net>
>> > Date: Sat, 23 Feb 2019 14:08:01 -0500
>> > Subject: [PATCH 1/1] gnu: tryton: Add tryton 5.0.6.
>> >
>> > * gnu/packages/tryton.scm (tryton-5): New variable.  
>> 
>> Do you think we should keep both version 4 and version 5?  Is it
>> generally useful today to have these two versions available?
>> 
> yeah it's very useful, tryton 4 and 5 both have updates, now 5 will be
> LTS

OK, sounds good.

>> > +(define-public tryton-5
>> > +  (package
>> > +    (name "tryton")
>> > +    (version "5.0.6")  
>> 
>> Should it inherit from ‘tryton’?
> what it's the best path for this?
> a guide please

You would write something like:

  (define-public tryton-5
    (package
      (inherit tryton)
      (version "5.0.6")
      ;; …
      ))

and you only need to specify fields that differ from those of ‘tryton’.
See for example ‘guile-2.0.13’ in (gnu packages guile).

>> > +    (license license:gpl3)))  
>> 
>> Version 3 only, or version 3 “or any later version”?
>> 
> http://hg.tryton.org/tryton/file/5.0/LICENSE
> yeah GPL-3+

Right, and specifically there are no source file headers that say
“version 3 only”, so ‘gpl3+’ indeed!

Thanks,
Ludo’.

PS: Please keep 34634@debbugs.gnu.org Cc’d.
Andreas Enge Sept. 5, 2020, 8:52 p.m. UTC | #4
We have tryton-5.6.0 now, so the problem is solved. Closing.

Andreas

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 31a2d481e..871537745 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
+;;; Copyright © 2019 Jovany Leandro G.C <bit4bit@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -96,6 +97,47 @@  and security.")
     (description "This package is the client component of Tryton.")
     (license license:gpl3+)))
 
+(define-public tryton-5
+  (package
+    (name "tryton")
+    (version "5.0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "tryton" version))
+       (sha256
+        (base32
+         "1lgkyyin5ydfl7qz692cvgswwyhnbc51r9krfz5k9rhq06ayaq4v"))))
+    (build-system python-build-system)
+    (arguments
+     `(;;_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix
will not be created.
+       #:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+               (wrap-program (string-append out "/bin/tryton")
+                 `("GI_TYPELIB_PATH" ":" prefix (, gi-typelib-path))))
+             #t))
+         (add-after 'unpack 'set-home-directory
+           ;; [Errno 13] Permission denied: '/homeless-shelter'
+           (lambda _ (setenv "HOME" "/tmp")
+                   #t))
+         )))
+    (native-inputs
+     `(("gtk+" ,gtk+)
+       ("librsvg" ,librsvg)))
+    (inputs
+     `(("python-pycairo" ,python-pycairo)
+       ("python-pygobject" ,python-pygobject)
+       ("python-dateutil" ,python-dateutil)))
+    (home-page "http://www.tryton.org/")
+    (synopsis "Client component of Tryton 5")
+    (description "This package is the client component of Tryton 5.")
+    (license license:gpl3)))
+
 (define-public python-trytond-country
   (package