[bug#34615] gnu: Add libtommath.

Message ID 20190222122736.GA18280@macbook41
State Accepted
Headers show
Series [bug#34615] gnu: Add libtommath. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Efraim Flashner Feb. 22, 2019, 12:27 p.m. UTC
Looks like I sent the email and forgot to add the patch to the package
definition patch.

Comments

Tobias Geerinckx-Rice Feb. 22, 2019, 10:30 p.m. UTC | #1
Efraim,

I noticed some PDF documentation that isn't currently installed. 
How about:

  (add-after 'build 'install-documentation
    (lambda* (#:key outputs #:allow-other-keys)
      (let* ((out (assoc-ref outputs "out"))
             (doc (string-append out "/share/doc/" ,name "-" 
             ,version)))
        (for-each (lambda (file) (install-file file doc))
                  (find-files "doc" "\\.pdf$"))
        #t))))

(This mail was supposed to be longer because it *is* possible to 
regenerate al least bn.pdf from the .tex sources, but an hour and 
6 GiB of texlive grafting later I don't have the energy to remove 
the non-determininstic date on their front page.  Foo.)

Kind regards,

T G-R
Efraim Flashner Feb. 24, 2019, 7:45 a.m. UTC | #2
On Fri, Feb 22, 2019 at 11:30:54PM +0100, Tobias Geerinckx-Rice wrote:
> Efraim,
> 
> I noticed some PDF documentation that isn't currently installed. How about:
> 
>  (add-after 'build 'install-documentation
>    (lambda* (#:key outputs #:allow-other-keys)
>      (let* ((out (assoc-ref outputs "out"))
>             (doc (string-append out "/share/doc/" ,name "-"
> ,version)))
>        (for-each (lambda (file) (install-file file doc))
>                  (find-files "doc" "\\.pdf$"))
>        #t))))
> 
> (This mail was supposed to be longer because it *is* possible to regenerate
> al least bn.pdf from the .tex sources, but an hour and 6 GiB of texlive
> grafting later I don't have the energy to remove the non-determininstic date
> on their front page.  Foo.)
> 

I wanted to keep the install size smaller so I hadn't planned on
installing the documentation. Considering we don't build the
documentation currently, if there are PDFs that are shipped with the
source I should probably delete those in a snippet.
Efraim Flashner Feb. 24, 2019, 8:52 a.m. UTC | #3
Pushed with changes suggested

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index faebff2e5d..73472fdc50 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -993,6 +993,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch	\
   %D%/packages/patches/libtar-CVE-2013-4420.patch 		\
   %D%/packages/patches/libtheora-config-guess.patch		\
+  %D%/packages/patches/libtommath-fix-linkage.patch		\
   %D%/packages/patches/libtool-skip-tests2.patch		\
   %D%/packages/patches/libusb-0.1-disable-tests.patch		\
   %D%/packages/patches/libusb-for-axoloti.patch			\
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index f9ae22b3f3..98dc414ac5 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -4,7 +4,7 @@ 
 ;;; Copyright © 2016, 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017, 2019 Eric Bavier <bavier@member.fsf.org>
@@ -1000,3 +1000,48 @@  objects.")
     ;; means that the gpl2+ licence of GAP itself applies, but to be on the
     ;; safe side, we drop them for now.
     (license license:gpl2+)))
+
+(define-public libtommath
+  (package
+    (name "libtommath")
+    (version "1.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://github.com/libtom/libtommath/releases/"
+                            "download/v" version "/ltm-" version ".tar.xz"))
+        (sha256
+         (base32
+          "1bbyagqzfdbg37k1n08nsqzdf44z8zsnjjinqbsyj7rxg246qilh"))
+        (patches (search-patches "libtommath-fix-linkage.patch"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure) ; no configure
+         (add-after 'unpack 'prepare-build
+           (lambda _
+             ;; Don't pull in coreutils.
+             (substitute* "makefile_include.mk"
+               (("arch") "uname -m"))
+             (delete-file "makefile")
+             (symlink "makefile.shared" "makefile")
+             #t))
+         (replace 'check
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (apply invoke "make" "test_standalone" make-flags)
+             (invoke "sh" "test")))
+         (add-after 'check 'make-static
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (apply invoke "make" "-f" "makefile.unix" "install" make-flags))))
+       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+                          "CC=gcc")))
+    (native-inputs
+     `(("libtool" ,libtool)))
+    (home-page "https://www.libtom.net/LibTomMath/")
+    (synopsis "portable number theoretic multiple-precision integer library")
+    (description "LibTomMath is a portable number theoretic multiple-precision
+integer library written entirely in C.  The library is designed to provide a
+simple to work with API that provides fairly efficient routines that build out
+of the box without configuration.")
+    (license license:unlicense)))
diff --git a/gnu/packages/patches/libtommath-fix-linkage.patch b/gnu/packages/patches/libtommath-fix-linkage.patch
new file mode 100644
index 0000000000..1a9d46eb7c
--- /dev/null
+++ b/gnu/packages/patches/libtommath-fix-linkage.patch
@@ -0,0 +1,55 @@ 
+https://github.com/libtom/libtommath/commit/93dea3a4162527346cd8856bfda6f17ffe98ab04.patch
+
+From 93dea3a4162527346cd8856bfda6f17ffe98ab04 Mon Sep 17 00:00:00 2001
+From: Steffen Jaeckel <s@jaeckel.eu>
+Date: Thu, 31 Jan 2019 14:12:03 +0100
+Subject: [PATCH] makefile.shared: fix compilation and linkage
+
+---
+ makefile.shared | 15 ++++++++-------
+ 1 file changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/makefile.shared b/makefile.shared
+index 3955f830..870b18d1 100644
+--- a/makefile.shared
++++ b/makefile.shared
+@@ -18,6 +18,7 @@ ifndef LIBTOOL
+   endif
+ endif
+ LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC)
++LTLINK = $(LIBTOOL) --mode=link --tag=CC $(CC)
+ 
+ LCOV_ARGS=--directory .libs --directory .
+ 
+@@ -59,7 +60,7 @@ objs: $(OBJECTS)
+ LOBJECTS = $(OBJECTS:.o=.lo)
+ 
+ $(LIBNAME):  $(OBJECTS)
+-	$(LIBTOOL) --mode=link --tag=CC $(CC) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
++	$(LTLINK) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
+ 
+ install: $(LIBNAME)
+ 	install -d $(DESTDIR)$(LIBPATH)
+@@ -76,16 +77,16 @@ uninstall:
+ 	rm $(DESTDIR)$(LIBPATH)/pkgconfig/libtommath.pc
+ 
+ test: $(LIBNAME) demo/demo.o
+-	$(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
+-	$(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
++	$(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
++	$(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
+ 
+ test_standalone: $(LIBNAME) demo/demo.o
+-	$(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
+-	$(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
++	$(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
++	$(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
+ 
+ .PHONY: mtest
+ mtest:
+-	cd mtest ; $(CC) $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
++	cd mtest ; $(CC) $(CFLAGS) -O0 mtest.c $(LDFLAGS) -o mtest
+ 
+ timing: $(LIBNAME) demo/timing.c
+-	$(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing
++	$(LTLINK) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing