[bug#34571] Add micropython

Message ID 20190219103704.GC32103@macbook41
State Accepted
Commit 20801f9da8cd8669837c4cf6dc633792be53a9f0
Headers show
Series [bug#34571] Add micropython | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Efraim Flashner Feb. 19, 2019, 10:37 a.m. UTC
On Tue, Feb 19, 2019 at 12:10:59PM +0200, Efraim Flashner wrote:
> On Tue, Feb 19, 2019 at 10:46:40AM +0100, Danny Milosavljevic wrote:
> > Hi Erfraim,
> > 
> > On Tue, 19 Feb 2019 11:22:16 +0200
> > Efraim Flashner <efraim@flashner.co.il> wrote:
> > 
> > > I was looking around to see if there was an alternate perl
> > > implementation and I ended up packaging micropython. I have no
> > > preference between it being in python.scm or embedded.scm
> > 
> > Heh :)
> > 
> > There's a bundled version of FreeRTOS in ./ports/cc3200 which is GPLv2
> > with a modification.
> > 
> > In this case, I suggest to delete FreeRTOS since we don't use it
> > anyway--and if we ever wanted to, we'd not use the bundled version.
> > So in a sense I suggest to unbundle it.
> > 
> > We could also just add GPLv2 with exception to the license list,
> > but in this case I wouldn't--since it doesn't really apply to the
> > installed version and we don't use it anyhow.
> 
> I'll go ahead and remove it.
> 
> > 
> > Also, there's a bundled copy of libffi in lib.  Usually, I delete
> > it to make sure it's not picked up by accident.
> > 
> Looking at the .gitmodules¹ it looks like there's a number of bundled
> librarires in the lib folder. With all of them removed it no longer
> builds. Looks like I need to take another look at it.
> 
> I also switched python-minimal-wrapper -> python-wrapper
> 
> ¹ https://github.com/micropython/micropython/blob/v1.10/.gitmodules
> 

I have a new version attached

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1c4ea720f..25f2ffa73 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -459,3 +459,65 @@  instead of @command{python3}.")))
 
 (define-public python-wrapper (wrap-python3 python))
 (define-public python-minimal-wrapper (wrap-python3 python-minimal))
+
+(define-public micropython
+  (package
+    (name "micropython")
+    (version "1.10")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://github.com/micropython/micropython/"
+                            "releases/download/v" version
+                            "/micropython-" version ".tar.gz"))
+        (sha256
+         (base32
+          "1g1zjip3rkx6bp16qi1bag72wivnbh56fcsl3nffanrx4j5f4z90"))
+      (modules '((guix build utils)))
+      (snippet
+       '(begin
+          (delete-file-recursively "ports/cc3200/FreeRTOS")
+          (with-directory-excursion "lib"
+            ;; TODO: Unbundle axtls and berkley-db-1.xx
+            (for-each delete-file-recursively
+                      '("libffi" "lwip" "stm32lib" "nrfx")))
+          #t))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'preprare-build
+           (lambda _
+             (chdir "ports/unix")
+             ;; see: https://github.com/micropython/micropython/pull/4246
+             (substitute* "Makefile"
+               (("-Os") "-Os -ffp-contract=off"))
+             #t))
+         (replace 'install-license-files
+           ;; We don't build in the root directory so the file isn't found.
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out  (assoc-ref outputs "out"))
+                    (dest (string-append out "/share/doc/" ,name "-" ,version "/")))
+               (install-file "../../LICENSE" dest))
+             #t))
+         (delete 'configure)) ; no configure
+       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+                          "V=1")
+       #:test-target "test"))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python" ,python-wrapper)))
+    (inputs
+     `(("libffi" ,libffi)))
+    (home-page "https://micropython.org/")
+    (synopsis "Python implementation for microcontrollers and constrained systems")
+    (description "MicroPython is a lean and efficient implementation of the
+Python 3 programming language that includes a small subset of the Python
+standard library and is optimised to run on microcontrollers and in constrained
+environments.  MicroPython is packed full of advanced features such as an
+interactive prompt, arbitrary precision integers, closures, list comprehension,
+generators, exception handling and more.  Still it is compact enough to fit and
+run within just 256k of code space and 16k of RAM.  MicroPython aims to be as
+compatible with normal Python as possible to allow you to transfer code with
+ease from the desktop to a microcontroller or embedded system.")
+    (license license:expat)))