[bug#34501] gnu: Remove unneeded uses of python-minimal.

Message ID 20190216174029.31799-1-mbakke@fastmail.com
State Accepted
Commit 61506fe551ed2237754dcaef569fff4645cd1a9d
Headers show
Series [bug#34501] gnu: Remove unneeded uses of python-minimal. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Marius Bakke Feb. 16, 2019, 5:40 p.m. UTC
The "python-minimal" package exists mostly to resolve a dependency cycle.  To
reduce duplication, packages should prefer the regular Python variants.

* gnu/packages/admin.scm (htop)[native-inputs]: Change PYTHON-MINIMAL-WRAPPER
to PYTHON-WRAPPER.
* gnu/packages/crypto.scm (botan)[native-inputs]: Likewise.
* gnu/packages/bioinformatics.scm (sambamba)[native-inputs]: Change
PYTHON-MINIMAL to PYTHON.
* gnu/packages/dictionaries.scm (apertium)[native-inputs]: Likewise.
* gnu/packages/databases.scm (mongodb)[native-inputs]: Change PYTHON2-MINIMAL
to PYTHON2.
* gnu/packages/games.scm (openttd-opensfx, openttd-openmsx)[native-inputs]:
Likewise.
* gnu/packages/gnome.scm (deja-dup)[native-inputs]: Likewise.
---
 gnu/packages/admin.scm          | 2 +-
 gnu/packages/bioinformatics.scm | 2 +-
 gnu/packages/crypto.scm         | 2 +-
 gnu/packages/databases.scm      | 2 +-
 gnu/packages/dictionaries.scm   | 2 +-
 gnu/packages/games.scm          | 4 ++--
 gnu/packages/gnome.scm          | 2 +-
 7 files changed, 8 insertions(+), 8 deletions(-)

Comments

Ricardo Wurmus Feb. 17, 2019, 11 a.m. UTC | #1
Marius Bakke <mbakke@fastmail.com> writes:

> The "python-minimal" package exists mostly to resolve a dependency cycle.  To
> reduce duplication, packages should prefer the regular Python variants.
>
> * gnu/packages/admin.scm (htop)[native-inputs]: Change PYTHON-MINIMAL-WRAPPER
> to PYTHON-WRAPPER.
> * gnu/packages/crypto.scm (botan)[native-inputs]: Likewise.
> * gnu/packages/bioinformatics.scm (sambamba)[native-inputs]: Change
> PYTHON-MINIMAL to PYTHON.
> * gnu/packages/dictionaries.scm (apertium)[native-inputs]: Likewise.
> * gnu/packages/databases.scm (mongodb)[native-inputs]: Change PYTHON2-MINIMAL
> to PYTHON2.
> * gnu/packages/games.scm (openttd-opensfx, openttd-openmsx)[native-inputs]:
> Likewise.
> * gnu/packages/gnome.scm (deja-dup)[native-inputs]: Likewise.

Looks good to me.  Thanks!

~~ Ricardo
swedebugia Feb. 21, 2019, 8:07 p.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> skrev: (17 februari 2019 12:00:08 CET)
>Marius Bakke <mbakke@fastmail.com> writes:
>
>> The "python-minimal" package exists mostly to resolve a dependency
>cycle.  To
>> reduce duplication, packages should prefer the regular Python
>variants.
>>
>> * gnu/packages/admin.scm (htop)[native-inputs]: Change
>PYTHON-MINIMAL-WRAPPER
>> to PYTHON-WRAPPER.
>> * gnu/packages/crypto.scm (botan)[native-inputs]: Likewise.
>> * gnu/packages/bioinformatics.scm (sambamba)[native-inputs]: Change
>> PYTHON-MINIMAL to PYTHON.
>> * gnu/packages/dictionaries.scm (apertium)[native-inputs]: Likewise.
>> * gnu/packages/databases.scm (mongodb)[native-inputs]: Change
>PYTHON2-MINIMAL
>> to PYTHON2.
>> * gnu/packages/games.scm (openttd-opensfx,
>openttd-openmsx)[native-inputs]:
>> Likewise.
>> * gnu/packages/gnome.scm (deja-dup)[native-inputs]: Likewise.
>
>Looks good to me.  Thanks!
>
>~~ Ricardo

Big thanks Marius!

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c0c991c137..a45c7ed874 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -298,7 +298,7 @@  graphs and can export its output to different formats.")
    (inputs
     `(("ncurses" ,ncurses)))
    (native-inputs
-    `(("python" ,python-minimal-wrapper))) ; for scripts/MakeHeader.py
+    `(("python" ,python-wrapper))) ; for scripts/MakeHeader.py
    (home-page "https://hisham.hm/htop/")
    (synopsis "Interactive process viewer")
    (description
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 933b8b9adf..69c85563e1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11192,7 +11192,7 @@  droplet sequencing.  It has been particularly tailored for Drop-seq.")
     (native-inputs
      `(("ldc" ,ldc)
        ("rdmd" ,rdmd)
-       ("python" ,python-minimal)
+       ("python" ,python)
        ("biod"
         ,(let ((commit "4f1a7d2fb7ef3dfe962aa357d672f354ebfbe42e"))
            (origin
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index ffef4ff8e4..0345a59285 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -751,7 +751,7 @@  SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R
          (replace 'check
            (lambda _ (invoke "./botan-test"))))))
     (native-inputs
-     `(("python" ,python-minimal-wrapper)
+     `(("python" ,python-wrapper)
        ("python-docutils" ,python-docutils)))
     (inputs
      `(("sqlite" ,sqlite)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 6129e3c0cb..e62e889f8c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -335,7 +335,7 @@  applications.")
     (native-inputs
      `(("valgrind" ,valgrind)
        ("perl" ,perl)
-       ("python" ,python2-minimal)
+       ("python" ,python-2)
        ("python2-pymongo" ,python2-pymongo)
        ("python2-pyyaml" ,python2-pyyaml)
        ("tzdata" ,tzdata)))
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 8c39453650..e0cd7604b6 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -372,7 +372,7 @@  word (e.g. cats) into its lemma \"cat\" and the grammatical information
        ("flex" ,flex)
        ("pkg-config" ,pkg-config)
        ;; python is only required for running the test suite
-       ("python-minimal" ,python-minimal)))
+       ("python" ,python)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6d9e63c4e9..bfbd370228 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2413,7 +2413,7 @@  OpenGFX provides you with...
     (build-system gnu-build-system)
     (native-inputs
      `(("catcodec" ,catcodec)
-       ("python" ,python2-minimal)))
+       ("python" ,python-2)))
     (arguments
      `(#:make-flags
        (list (string-append "INSTALL_DIR=" %output
@@ -2450,7 +2450,7 @@  the original Transport Tycoon Deluxe.")
          "0nskq97a6fsv1v6d62zf3yb8whzhqnlh3lap3va3nzvj7csjgf7c"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("python" ,python2-minimal)))
+     `(("python" ,python-2)))
     (arguments
      `(#:make-flags
        (list (string-append "INSTALL_DIR=" %output
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2f99755933..8753be7890 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -277,7 +277,7 @@  features to enable users to create their discs easily and quickly.")
      `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gobject-introspection" ,gobject-introspection)
        ("duplicity" ,duplicity)
-       ("python" ,python2-minimal)
+       ("python" ,python-2)
        ("python-pygobject" ,python2-pygobject)
        ("gtk+" ,gtk+)
        ("libnotify" ,libnotify)