[bug#34482,3/3] gnu: freedink-engine: Update to 109.4.

Message ID 20190215122624.5269-2-kkebreau@posteo.net
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Kei Kebreau Feb. 15, 2019, 12:26 p.m. UTC
* gnu/packages/games.scm (freedink-engine): Update to 109.4.
[arguments]: Add 'disable-graphical-tests' phase.
[native-inputs]: Add autoconf, automake and cxxtest.  Remove check.
[inputs]: Add glm and sdl-union of sdl2, sdl2-image, sdl2-mixer, sdl2-ttf and
sdl2-gfx.  Remove sdl, sdl-image, sdl-mixer, sdl-ttf and sdl-gfx.
---
 gnu/packages/games.scm | 32 +++++++++++++++++++++-----------
 1 file changed, 21 insertions(+), 11 deletions(-)

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6d9e63c4e9..980bf872e7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -112,6 +112,7 @@ 
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages haskell)
+  #:use-module (gnu packages maths)
   #:use-module (gnu packages mp3)
   #:use-module (gnu packages music)
   #:use-module (gnu packages multiprecision)
@@ -1401,25 +1402,34 @@  interface or via an external visual interface such as GNU XBoard.")
 (define freedink-engine
   (package
     (name "freedink-engine")
-    (version "108.4")
+    (version "109.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/freedink/freedink-" version
                                   ".tar.gz"))
               (sha256
                (base32
-                "08c51imfjfcydm7h0va09z8qfw5nc837bi2x754ni2z737hb5kw2"))))
+                "0iaagwnyfgm3mqzkj550q60hrsjr13gykg5vfn2nz2ia520bb52g"))))
     (build-system gnu-build-system)
-    (arguments `(#:configure-flags '("--disable-embedded-resources")))
-    (native-inputs `(("gettext" ,gettext-minimal)
-                     ("pkg-config" ,pkg-config)))
-    (inputs `(("sdl" ,sdl)
-              ("sdl-image" ,sdl-image)
-              ("sdl-mixer" ,sdl-mixer)
-              ("sdl-ttf" ,sdl-ttf)
-              ("sdl-gfx" ,sdl-gfx)
+    (arguments
+     `(#:configure-flags '("--disable-embedded-resources")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'disable-graphical-tests
+           (lambda _
+             ;; These tests require a graphical interface.
+             (substitute* "src/Makefile.am"
+               (("test_gfx_fonts TestIOGfxDisplay") ""))
+             #t)))))
+    (native-inputs `(("autoconf" ,autoconf)
+                     ("automake" ,automake)
+                     ("gettext" ,gettext-minimal)
+                     ("pkg-config" ,pkg-config)
+                     ("cxxtest" ,cxxtest)))
+    (inputs `(("sdl-union" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer
+                                             sdl2-ttf sdl2-gfx)))
               ("fontconfig" ,fontconfig)
-              ("check" ,check)))
+              ("glm" ,glm)))
     (properties '((ftp-directory . "/freedink")
                   (upstream-name . "freedink")))
     (home-page "https://www.gnu.org/software/freedink/")