[bug#34482,1/3] gnu: Add sdl2-gfx.

Message ID 20190215063530.31198-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#34482,1/3] gnu: Add sdl2-gfx. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Kei Kebreau Feb. 15, 2019, 6:35 a.m. UTC
* gnu/packages/sdl.scm (sdl2-gfx): New variable.
---
 gnu/packages/sdl.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Leo Famulari Feb. 15, 2019, 4:39 p.m. UTC | #1
On Fri, Feb 15, 2019 at 01:35:30AM -0500, Kei Kebreau wrote:
> * gnu/packages/sdl.scm (sdl2-gfx): New variable.

> +               (string-append "http://www.frezkopp.net/Software/SDL2_gfx/SDL2_gfx-"
> +                              version ".tar.gz"))

I think there is a typo in this URL.

s/frez/ferz
Efraim Flashner Feb. 17, 2019, 10:22 a.m. UTC | #2
On Fri, Feb 15, 2019 at 11:39:09AM -0500, Leo Famulari wrote:
> On Fri, Feb 15, 2019 at 01:35:30AM -0500, Kei Kebreau wrote:
> > * gnu/packages/sdl.scm (sdl2-gfx): New variable.
> 
> > +               (string-append "http://www.frezkopp.net/Software/SDL2_gfx/SDL2_gfx-"
> > +                              version ".tar.gz"))
> 
> I think there is a typo in this URL.
> 
> s/frez/ferz

Is the url even still valid? I though they got a domain squatter there
now
Kei Kebreau Feb. 17, 2019, 5:15 p.m. UTC | #3
Efraim Flashner <efraim@flashner.co.il> writes:

> On Fri, Feb 15, 2019 at 11:39:09AM -0500, Leo Famulari wrote:
>> On Fri, Feb 15, 2019 at 01:35:30AM -0500, Kei Kebreau wrote:
>> > * gnu/packages/sdl.scm (sdl2-gfx): New variable.
>> 
>> > + (string-append
>> > "http://www.frezkopp.net/Software/SDL2_gfx/SDL2_gfx-"
>> > +                              version ".tar.gz"))
>> 
>> I think there is a typo in this URL.
>> 
>> s/frez/ferz
>
> Is the url even still valid? I though they got a domain squatter there
> now

I navigated through the website to get to the SDL2_gfx tarball which was
last updated about a year ago, so I think it's still valid. Below is the
relevant page:

http://www.ferzkopp.net/wordpress/2016/01/02/sdl_gfx-sdl2_gfx/
Kei Kebreau Feb. 23, 2019, 1:41 a.m. UTC | #4
Since there have been no further corrections, I've pushed a slightly
modified version of this patch to master. Thanks to all involved for
reviewing!

Patch

diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index a1522792a7..30b48a5215 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -348,6 +349,21 @@  directory.")
          (other other))
        (package-propagated-inputs package)))
 
+(define-public sdl2-gfx
+  (package (inherit sdl-gfx)
+    (name "sdl2-gfx")
+    (version "1.0.4")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "http://www.frezkopp.net/Software/SDL2_gfx/SDL2_gfx-"
+                              version ".tar.gz"))
+              (sha256
+               (base32
+                "0qk2ax7f7grlxb13ba0ll3zlm8780s7j8fmrhlpxzjgdvldf1q33"))))
+    (propagated-inputs
+     (propagated-inputs-with-sdl2 sdl-gfx))))
+
 (define-public sdl2-image
   (package (inherit sdl-image)
     (name "sdl2-image")