[bug#34453] build guile-static with guile-2.0

Message ID 20190212091740.GB3284@macbook41
State Accepted
Headers show
Series [bug#34453] build guile-static with guile-2.0 | expand

Commit Message

Efraim Flashner Feb. 12, 2019, 9:17 a.m. UTC
When experimenting I found that using guile@2.0 as a base for
guile-static, the resulting guile-static didn't segfault on the target
architecture.

Comments

Ludovic Courtès Feb. 16, 2019, 4:06 p.m. UTC | #1
Hi Efraim,

Efraim Flashner <efraim@flashner.co.il> skribis:

> When experimenting I found that using guile@2.0 as a base for
> guile-static, the resulting guile-static didn't segfault on the target
> architecture.

As discussed in <https://issues.guix.info/issue/34427>, I would rather
fix the segfault in 2.2 than move back to 2.0 and effectively delay the
problem.

Ludo’.
Simon Tournier April 12, 2022, 10:10 a.m. UTC | #2
Hi,

What is the status of this old patch #34453?

http://issues.guix.gnu.org/issue/34453


On Sat, 16 Feb 2019 at 17:06, Ludovic Courtès <ludo@gnu.org> wrote:
> Efraim Flashner <efraim@flashner.co.il> skribis:
>
>> When experimenting I found that using guile@2.0 as a base for
>> guile-static, the resulting guile-static didn't segfault on the target
>> architecture.
>
> As discussed in <https://issues.guix.info/issue/34427>, I would rather
> fix the segfault in 2.2 than move back to 2.0 and effectively delay the
> problem.

Note that #34427 is still open.


Cheers,
simon
Efraim Flashner April 13, 2022, 9:07 p.m. UTC | #3
On Tue, Apr 12, 2022 at 12:10:09PM +0200, zimoun wrote:
> Hi,
> 
> What is the status of this old patch #34453?
> 
> http://issues.guix.gnu.org/issue/34453
> 
> 
> On Sat, 16 Feb 2019 at 17:06, Ludovic Courtès <ludo@gnu.org> wrote:
> > Efraim Flashner <efraim@flashner.co.il> skribis:
> >
> >> When experimenting I found that using guile@2.0 as a base for
> >> guile-static, the resulting guile-static didn't segfault on the target
> >> architecture.
> >
> > As discussed in <https://issues.guix.info/issue/34427>, I would rather
> > fix the segfault in 2.2 than move back to 2.0 and effectively delay the
> > problem.
> 
> Note that #34427 is still open.

We can probably drop it. We'll pick it back up again if/when it comes up
again.
Simon Tournier June 23, 2022, 8:14 a.m. UTC | #4
Hi,

On Thu, 14 Apr 2022 at 00:07, Efraim Flashner <efraim@flashner.co.il> wrote:
> On Tue, Apr 12, 2022 at 12:10:09PM +0200, zimoun wrote:
>> On Sat, 16 Feb 2019 at 17:06, Ludovic Courtès <ludo@gnu.org> wrote:
>> > Efraim Flashner <efraim@flashner.co.il> skribis:

>> > As discussed in <https://issues.guix.info/issue/34427>, I would rather
>> > fix the segfault in 2.2 than move back to 2.0 and effectively delay the
>> > problem.
>>
>> Note that #34427 is still open.
>
> We can probably drop it. We'll pick it back up again if/when it comes up
> again.

Therefore, I am closing.


Cheers,
simon

Patch

diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index c6002eb63a..836f24debf 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,6 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
 ;;;
@@ -518,29 +518,29 @@  for `sh' in $PATH, and without nscd, and with static NSS modules."
   ;; .scm and .go files relative to its installation directory, rather
   ;; than in hard-coded configure-time paths.
   (let* ((patches (cons* (search-patch "guile-relocatable.patch")
-                         (search-patch "guile-2.2-default-utf8.patch")
+                         (search-patch "guile-default-utf8.patch")
                          (search-patch "guile-linux-syscalls.patch")
-                         (origin-patches (package-source guile-2.2))))
-         (source  (origin (inherit (package-source guile-2.2))
+                         (origin-patches (package-source guile-2.0))))
+         (source  (origin (inherit (package-source guile-2.0))
                     (patches patches)))
-         (guile (package (inherit guile-2.2)
-                  (name (string-append (package-name guile-2.2) "-static"))
+         (guile (package (inherit guile-2.0)
+                  (name (string-append (package-name guile-2.0) "-static"))
                   (source source)
                   (synopsis "Statically-linked and relocatable Guile")
 
                   ;; Remove the 'debug' output (see above for the reason.)
-                  (outputs (delete "debug" (package-outputs guile-2.2)))
+                  (outputs (delete "debug" (package-outputs guile-2.0)))
 
                   (inputs
                    `(("libunistring:static" ,libunistring "static")
-                     ,@(package-inputs guile-2.2)))
+                     ,@(package-inputs guile-2.0)))
 
                   (propagated-inputs
                    `(("bdw-gc" ,libgc)
                      ,@(alist-delete "bdw-gc"
-                                     (package-propagated-inputs guile-2.2))))
+                                     (package-propagated-inputs guile-2.0))))
                   (arguments
-                   (substitute-keyword-arguments (package-arguments guile-2.2)
+                   (substitute-keyword-arguments (package-arguments guile-2.0)
                      ((#:configure-flags flags '())
                       ;; When `configure' checks for ltdl availability, it
                       ;; doesn't try to link using libtool, and thus fails
@@ -563,7 +563,7 @@  for `sh' in $PATH, and without nscd, and with static NSS modules."
                                (("^guile_LDFLAGS =")
                                 "guile_LDFLAGS = -all-static")
 
-                               ;; Add `-ldl' *after* libguile-2.2.la.
+                               ;; Add `-ldl' *after* libguile-2.0.la.
                                (("^guile_LDADD =(.*)$" _ ldadd)
                                 (string-append "guile_LDADD = "
                                                (string-trim-right ldadd)
@@ -591,13 +591,13 @@  for `sh' in $PATH, and without nscd, and with static NSS modules."
                 (out    (assoc-ref %outputs "out"))
                 (guile1 (string-append in "/bin/guile"))
                 (guile2 (string-append out "/bin/guile")))
-           (mkdir-p (string-append out "/share/guile/2.2"))
-           (copy-recursively (string-append in "/share/guile/2.2")
-                             (string-append out "/share/guile/2.2"))
+           (mkdir-p (string-append out "/share/guile/2.0"))
+           (copy-recursively (string-append in "/share/guile/2.0")
+                             (string-append out "/share/guile/2.0"))
 
-           (mkdir-p (string-append out "/lib/guile/2.2/ccache"))
-           (copy-recursively (string-append in "/lib/guile/2.2/ccache")
-                             (string-append out "/lib/guile/2.2/ccache"))
+           (mkdir-p (string-append out "/lib/guile/2.0/ccache"))
+           (copy-recursively (string-append in "/lib/guile/2.0/ccache")
+                             (string-append out "/lib/guile/2.0/ccache"))
 
            (mkdir (string-append out "/bin"))
            (copy-file guile1 guile2)