[bug#34435,2/3] gnu: Add kdecoration.

Message ID 20190211151835.18653-2-mbakke@fastmail.com
State Accepted
Headers show
Series KDE updates | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Marius Bakke Feb. 11, 2019, 3:18 p.m. UTC
From: Hartmut Goebel <h.goebel@crazy-compilers.com>

* gnu/packages/kde.scm (kdecoration): New public variable.

Co-authored-by: Marius Bakke <mbakke@fastmail.com>
---
 gnu/packages/kde.scm | 33 ++++++++++++++++++++++++++++++++-
 1 file changed, 32 insertions(+), 1 deletion(-)

Comments

Hartmut Goebel Feb. 12, 2019, 8:39 a.m. UTC | #1
Am 11.02.19 um 16:18 schrieb Marius Bakke:
> +         (add-before 'check 'check-setup
> +           (lambda _ (setenv "QT_QPA_PLATFORM" "offscreen") #t)))))

All in one line? It this the new style?

Otherwise LGTM

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 36f7f234c8..3508e8461f 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -4,7 +4,8 @@ 
 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -59,6 +60,36 @@ 
   #:use-module (gnu packages video)
   #:use-module (gnu packages xorg))
 
+(define-public kdecoration
+  (package
+    (name "kdecoration")
+    (version "5.14.5")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://kde/stable/plasma/" version
+                          "/kdecoration-" version ".tar.xz"))
+      (sha256
+       (base32 "115pli0qpa8lx0jasg1886fcg7gb2kk8v6k8r8l8c820l97sq7in"))))
+    (properties `((tags . '("Desktop" "KDE" "Plasma"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("ki18n" ,ki18n)
+       ("qtbase" ,qtbase)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'check-setup
+           (lambda _ (setenv "QT_QPA_PLATFORM" "offscreen") #t)))))
+    (home-page "https://cgit.kde.org/kdecoration.git")
+    (synopsis "Plugin based library to create window decorations")
+    (description "KDecoration is a library to create window decorations.
+These window decorations can be used by for example an X11 based window
+manager which re-parents a client window to a window decoration frame.")
+    (license license:lgpl3+)))
+
 (define-public kdenlive
   (let ((version "18.08.1"))
     (package