[bug#34434] gnu: Add frrouting.

Message ID 20190211134836.21655-1-boskovits@gmail.com
State Accepted
Headers show
Series [bug#34434] gnu: Add frrouting. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Gábor Boskovits Feb. 11, 2019, 1:48 p.m. UTC
* gnu/packages/networking.scm (frrouting): New variable.
---
 gnu/packages/networking.scm | 38 ++++++++++++++++++++++++++++++++++++-
 1 file changed, 37 insertions(+), 1 deletion(-)

Comments

Ricardo Wurmus Feb. 11, 2019, 8:37 p.m. UTC | #1
Gábor Boskovits <boskovits@gmail.com> writes:

> * gnu/packages/networking.scm (frrouting): New variable.
> ---
>  gnu/packages/networking.scm | 38 ++++++++++++++++++++++++++++++++++++-
>  1 file changed, 37 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index c71ae4a24d..f58e1d7548 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -16,7 +16,7 @@
>  ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
>  ;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
>  ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
> -;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
> +;;; Copyright © 2017, 2018 Gábor Boskovits <boskovits@gmail.com>

The current year is 2019.

>  ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
>  ;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
>  ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
> @@ -98,6 +98,7 @@
>    #:use-module (gnu packages textutils)
>    #:use-module (gnu packages tls)
>    #:use-module (gnu packages valgrind)
> +  #:use-module (gnu packages web)
>    #:use-module (gnu packages wm)
>    #:use-module (gnu packages wxwidgets)
>    #:use-module (gnu packages xml)
> @@ -2367,3 +2368,38 @@ communication over HTTP.")
>  be used to manage peer-to-peer network connections as needed for real time
>  communication.")
>      (license license:gpl3+)))
> +
> +(define-public frrouting
> +  (package
> +    (name "frrouting")
> +    (version "6.0.2")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/FRRouting/frr.git")
> +                    (commit (string-append "frr-" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "15ycl0maak55n9xvlz3zbsskqc7901sy5h67jz0068hxc0kh6jpj"))))

Have you seen that they have official release tarballs?

    https://github.com/FRRouting/frr/releases/download/frr-6.0.2/frr-6.0.2.tar.xz

> +    (build-system gnu-build-system)
> +    (inputs
> +     `(("c-ares" ,c-ares)
> +       ("json-c" ,json-c)
> +       ("readline" ,readline)))
> +    (native-inputs
> +     `(("autoconf" ,autoconf)
> +       ("automake" ,automake)

You might not need these when using the release tarball.

> +    (description "FRRouting (FRR) is an IP routing protocol suite for Linux and
> +Unix platforms which includes protocol daemons for BGP, IS-IS, LDP, OSPF, PIM,
> +and RIP. ")

I’d remove “for Linux and Unix platforms”.

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c71ae4a24d..f58e1d7548 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -16,7 +16,7 @@ 
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2017, 2018 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -98,6 +98,7 @@ 
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages valgrind)
+  #:use-module (gnu packages web)
   #:use-module (gnu packages wm)
   #:use-module (gnu packages wxwidgets)
   #:use-module (gnu packages xml)
@@ -2367,3 +2368,38 @@  communication over HTTP.")
 be used to manage peer-to-peer network connections as needed for real time
 communication.")
     (license license:gpl3+)))
+
+(define-public frrouting
+  (package
+    (name "frrouting")
+    (version "6.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/FRRouting/frr.git")
+                    (commit (string-append "frr-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "15ycl0maak55n9xvlz3zbsskqc7901sy5h67jz0068hxc0kh6jpj"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("c-ares" ,c-ares)
+       ("json-c" ,json-c)
+       ("readline" ,readline)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("bison" ,bison)
+       ("flex" ,flex)
+       ("libtool" ,libtool)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python-wrapper)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://frrouting.org/")
+    (synopsis "IP routing protocol suite")
+    (description "FRRouting (FRR) is an IP routing protocol suite for Linux and
+Unix platforms which includes protocol daemons for BGP, IS-IS, LDP, OSPF, PIM,
+and RIP. ")
+    (license license:gpl2+)))