[bug#34406] gnu: flatpak: Add missing dependencies

Message ID 20190209171243.27305-1-me@aimileus.nl
State Accepted
Headers show
Series [bug#34406] gnu: flatpak: Add missing dependencies | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Emiel Wiedijk Feb. 9, 2019, 5:12 p.m. UTC
* Add gnupg to propagated inputs: flatpak uses gpgme to verify
  repositories, this requires a gpg binary in $PATH, otherwise I get
  this error:
    "GPGME error: Invalid crypto engine"
* Add gsettings-desktop-schemas to propagated inputs: flatpak also
  depends on gsettings-desktop-schemas. Apparantly it is available by
  default on my GNOME desktop, so it works if I run it unprivileged.
  However, in a root prompt, it emits this error message:
    "(flatpak remote-add:19956): GLib-GIO-ERROR **: 09:05:00.003:
     Settings schema 'org.gnome.system.proxy' is not installed"
  The same error occurs, with the package in inputs. For me, flatpak as
  root only works with gsettings-desktop-schemas in propagated-inputs.
---
 gnu/packages/package-management.scm | 3 +++
 1 file changed, 3 insertions(+)

Comments

Emiel Wiedijk Feb. 9, 2019, 6:16 p.m. UTC | #1
I am not sure whether adding gnupg and gsettings-desktop-schemas to
propagated-inputs is the correct approach. For example, I see that the
password-store package uses a wrapper script to add gnupg and git to $PATH.
Maybe that is the preferred way?
Rutger Helling March 8, 2019, 10:58 a.m. UTC | #2
Pushed along with another missing dependency, thanks!

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c3b195a64..0ab5ce652 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -50,6 +50,7 @@ 
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gnuzilla)
   #:use-module (gnu packages graphviz)
+  #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages guile-xyz)
@@ -980,6 +981,8 @@  the bootloader configuration.")
                          (string-append "--with-system-bubblewrap="
                                         (assoc-ref %build-inputs "bubblewrap")
                                         "/bin/bwrap"))))
+   (propagated-inputs `(("gnupg" ,gnupg)
+                        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
    (native-inputs `(("bison" ,bison)
                     ("gettext" ,gnu-gettext)
                     ("glib:bin" ,glib "bin") ; for glib-mkenums + gdbus-codegen