[bug#34283,PATCH-2/4] Add: libmypaint@2.0.0-alpha

Message ID 20190208072416.pdynd5r5po3l2ru7@WaraToNora
State Accepted
Headers show
Series [bug#34283] Add: mypaint | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Yoshinori Arai Feb. 8, 2019, 7:24 a.m. UTC
From 9eb0cea3a515c4bf927758578e105e1125d54c8f Mon Sep 17 00:00:00 2001
From: Yoshinori Arai <kumagusu08@gmail.com>
Date: Fri, 8 Feb 2019 12:53:49 +0900
Subject: [PATCH 2/4] Add: libmypaint@2.0.0-alpha

---
 gnu/packages/graphics.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 6663ff7dc..cdccc9372 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -911,3 +911,25 @@  requirements.")
     (synopsis "Simple drawing and painting program")
     (description "MyPaint is a fast and easy graphics app for digital painters.")
     (license license:gpl2+)))
+
+(define-public libmypaint-2
+  (package (inherit libmypaint)
+           (version "2.0.0-alpha")
+           (source (origin
+                     (method url-fetch)
+                     (uri (string-append "https://github.com/mypaint/libmypaint/"
+                                         "archive/v" version ".0.tar.gz"))
+                     (sha256
+                      (base32
+                       "1qbmjj7rammw4rma0jawff7q32d4gsy63f11af8dhk07bk4rkxph"))))
+           ;;MyPaint and libmypaint benefit dramatically from autovectorization
+           ;;and other compiler optimizations. from README.md
+           (arguments
+            `(#:make-flags (list "CFLAGS=-Ofast -ftree-vectorize -fopt-info-vec-optimized -march=native -mtune=native -funsafe-math-optimizations -funsafe-loop-optimizations")))
+           (native-inputs
+            `(("intltool" ,intltool)
+              ("libtool" ,libtool)
+              ("automake" ,automake)
+              ("autoconf" ,autoconf)
+              ("python-2" ,python-2)  ;need to generate headers in autogen.sh
+              ("pkg-config" ,pkg-config)))))