[bug#34283,PATCH-1/4] Add: mypaint@1.2.1

Message ID 20190208072240.sbx6xmzheyxyinkw@WaraToNora
State Accepted
Headers show
Series [bug#34283,PATCH-1/4] Add: mypaint@1.2.1 | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Yoshinori Arai Feb. 8, 2019, 7:22 a.m. UTC
From 9fe8e0b3cb260da2bae0de7c2c5d0963c4f543a6 Mon Sep 17 00:00:00 2001
From: Yoshinori Arai <kumagusu08@gmail.com>
Date: Fri, 8 Feb 2019 12:41:11 +0900
Subject: [PATCH 1/4] Add: mypaint@1.2.1

---
 gnu/packages/graphics.scm | 55 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 55 insertions(+)

Comments

swedebugia June 28, 2019, 5:34 a.m. UTC | #1
On 2019-02-08 08:22, Yoshinori Arai wrote:
>  From 9fe8e0b3cb260da2bae0de7c2c5d0963c4f543a6 Mon Sep 17 00:00:00 2001
> From: Yoshinori Arai <kumagusu08@gmail.com>
> Date: Fri, 8 Feb 2019 12:41:11 +0900
> Subject: [PATCH 1/4] Add: mypaint@1.2.1
> 
> ---
>   gnu/packages/graphics.scm | 55 +++++++++++++++++++++++++++++++++++++++
>   1 file changed, 55 insertions(+)
> 
> diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
> index bf4cc89b0..6663ff7dc 100644
> --- a/gnu/packages/graphics.scm
> +++ b/gnu/packages/graphics.scm
> @@ -41,7 +41,9 @@
>     #:use-module (gnu packages flex)
>     #:use-module (gnu packages fonts)
>     #:use-module (gnu packages fontutils)
> +  #:use-module (gnu packages gettext)
>     #:use-module (gnu packages ghostscript)
> +  #:use-module (gnu packages gimp)
>     #:use-module (gnu packages gl)
>     #:use-module (gnu packages glib)
>     #:use-module (gnu packages gnome)
> @@ -70,6 +72,7 @@
>     #:use-module (guix build-system cmake)
>     #:use-module (guix build-system gnu)
>     #:use-module (guix build-system python)
> +  #:use-module (guix build-system scons)
>     #:use-module (guix download)
>     #:use-module (guix git-download)
>     #:use-module ((guix licenses) #:prefix license:)
> @@ -856,3 +859,55 @@ your terminal.  It comes bundled with predefined styles:
>   look.  The result can be uploaded on any web server without additional
>   requirements.")
>       (license license:gpl2+)))
> +
> +(define-public mypaint
> +  (package
> +    (name "mypaint")
> +    (version "1.2.1")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://github.com/" name "/" name
> +                                  "/releases/download/v" version
> +                                  "/" name "-" version ".tar.xz"))
> +              (sha256
> +               (base32
> +                "1iykjvfis5y71wn9wyxpmha7vb4pgr10dbpgglymh33a5ww4j8zd"))))
> +    (build-system scons-build-system)
> +    (arguments
> +     `(#:tests? #f  ;; need graphical environment
> +       #:scons ,scons-python2
> +       #:scons-flags
> +       (list (string-append "numpy_include="
> +                            (assoc-ref %build-inputs "python2-numpy")
> +                            "/lib/python2.7/site-packages/numpy/core/include")
> +             (string-append "prefix=" (assoc-ref %outputs "out")))))
> +       ;; README_LINUX.md
> +       ;;-If testing outside a graphical environment (anywhere Gdk refuses
> +       ;; to initialize), limit the doctests to just `lib/` and `brushlib/`.
> +       ;;-There are several interactive GUI tests in the `tests/` folder
> +       ;; which `nosetests` does not run - quite intentionally -
> +       ;; because their executable bit is set.
> +       ;;#:phases
> +       ;;(modify-phases %standard-phases
> +       ;;  (replace 'check
> +       ;;    (lambda _
> +       ;;      (invoke "nosetests" "--with-doctest"))))))
> +    (native-inputs
> +     `(("pkg-config" ,pkg-config)
> +       ("python" ,python-2)
> +       ("lcms" ,lcms)
> +       ("swig" ,swig)))
> +       ;;("python-nose" ,python2-nose)))   ;; for test
> +    (inputs
> +     `(("gettext" ,gettext-minimal)
> +       ("libmypaint" ,libmypaint)
> +       ("mypaint-brushes" ,mypaint-brushes)))
> +    (propagated-inputs
> +     `(("gtk+" ,gtk+)
> +       ("python2-pygobject" ,python2-pygobject)
> +       ("python2-numpy" ,python2-numpy)
> +       ("python2-pycairo" ,python2-pycairo)))
> +    (home-page "http://mypaint.org/")
> +    (synopsis "Simple drawing and painting program")
> +    (description "MyPaint is a fast and easy graphics app for digital painters.")
> +    (license license:gpl2+)))
> 

This has slipped through the cracks. Can someone with gtk-knowledge 
please review?

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index bf4cc89b0..6663ff7dc 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -41,7 +41,9 @@ 
   #:use-module (gnu packages flex)
   #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
+  #:use-module (gnu packages gimp)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
@@ -70,6 +72,7 @@ 
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system scons)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
@@ -856,3 +859,55 @@  your terminal.  It comes bundled with predefined styles:
 look.  The result can be uploaded on any web server without additional
 requirements.")
     (license license:gpl2+)))
+
+(define-public mypaint
+  (package
+    (name "mypaint")
+    (version "1.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/" name "/" name
+                                  "/releases/download/v" version
+                                  "/" name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1iykjvfis5y71wn9wyxpmha7vb4pgr10dbpgglymh33a5ww4j8zd"))))
+    (build-system scons-build-system)
+    (arguments
+     `(#:tests? #f  ;; need graphical environment
+       #:scons ,scons-python2
+       #:scons-flags
+       (list (string-append "numpy_include="
+                            (assoc-ref %build-inputs "python2-numpy")
+                            "/lib/python2.7/site-packages/numpy/core/include")
+             (string-append "prefix=" (assoc-ref %outputs "out")))))
+       ;; README_LINUX.md
+       ;;-If testing outside a graphical environment (anywhere Gdk refuses
+       ;; to initialize), limit the doctests to just `lib/` and `brushlib/`.
+       ;;-There are several interactive GUI tests in the `tests/` folder
+       ;; which `nosetests` does not run - quite intentionally -
+       ;; because their executable bit is set.
+       ;;#:phases
+       ;;(modify-phases %standard-phases
+       ;;  (replace 'check
+       ;;    (lambda _
+       ;;      (invoke "nosetests" "--with-doctest"))))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python" ,python-2)
+       ("lcms" ,lcms)
+       ("swig" ,swig)))
+       ;;("python-nose" ,python2-nose)))   ;; for test
+    (inputs
+     `(("gettext" ,gettext-minimal)
+       ("libmypaint" ,libmypaint)
+       ("mypaint-brushes" ,mypaint-brushes)))
+    (propagated-inputs
+     `(("gtk+" ,gtk+)
+       ("python2-pygobject" ,python2-pygobject)
+       ("python2-numpy" ,python2-numpy)
+       ("python2-pycairo" ,python2-pycairo)))
+    (home-page "http://mypaint.org/")
+    (synopsis "Simple drawing and painting program")
+    (description "MyPaint is a fast and easy graphics app for digital painters.")
+    (license license:gpl2+)))