[bug#34344] gnu: Add guile-squee.

Message ID 20190206111303.3476-1-mail@cbaines.net
State Accepted
Commit 61dafdc0fee97dc1ee5016edc50ed1abd60464f7
Headers show
Series [bug#34344] gnu: Add guile-squee. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Feb. 6, 2019, 11:13 a.m. UTC
* gnu/packages/guile-xyz.scm (guile-squee): New variable.
---
 gnu/packages/guile-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Ricardo Wurmus Feb. 6, 2019, 1 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> * gnu/packages/guile-xyz.scm (guile-squee): New variable.

LGTM!
Ricardo Wurmus Feb. 6, 2019, 1:03 p.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/guile-xyz.scm (guile-squee): New variable.
>
> LGTM!

Actually, no!  The license is wrong.  It should be LGPLv3+, not GPLv3+.

--
Ricardo
Christopher Baines Feb. 6, 2019, 1:12 p.m. UTC | #3
Ricardo Wurmus <rekado@elephly.net> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/guile-xyz.scm (guile-squee): New variable.
>
> LGTM!

Great, I've pushed this to master now.
Christopher Baines Feb. 8, 2019, 10:28 a.m. UTC | #4
Ricardo Wurmus <rekado@elephly.net> writes:

> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Christopher Baines <mail@cbaines.net> writes:
>>
>>> * gnu/packages/guile-xyz.scm (guile-squee): New variable.
>>
>> LGTM!
>
> Actually, no!  The license is wrong.  It should be LGPLv3+, not GPLv3+.

Ah yes, I should have paid more attention. I've pushed a correction as
[1].

1: 6fd72f7094885dc3dbb10431996c445251094915

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 117d309c92..f249761ebc 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -560,6 +560,45 @@  HTML (via SXML) or any other format for rendering.")
 It has a nice, simple s-expression based syntax.")
     (license license:lgpl3+)))
 
+(define-public guile-squee
+  (let ((commit "a85902a92bf6f58a1d35fd974a01ade163deda8d")
+        (revision "0"))
+    (package
+      (name "guile-squee")
+      (version (string-append "0-" revision "." (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://notabug.org/cwebber/guile-squee.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0p1lpsp4kx57j3ai1dkxilm4ziavzzx8wbbc42m3hpziq0a7qz5z"))))
+      (build-system guile-build-system)
+      (arguments
+       '(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'patch
+             (lambda* (#:key inputs #:allow-other-keys)
+               (substitute* "squee.scm"
+                 (("dynamic-link \"libpq\"")
+                  (string-append
+                   "dynamic-link \""
+                   (assoc-ref inputs "postgresql") "/lib/libpq.so"
+                   "\"")))
+               #t)))))
+      (inputs
+       `(("postgresql" ,postgresql)))
+      (native-inputs
+       `(("guile" ,guile-2.2)))
+      (home-page "https://notabug.org/cwebber/guile-squee")
+      (synopsis "Connect to PostgreSQL using Guile")
+      (description
+       "@code{squee} is a Guile library for connecting to PostgreSQL databases
+using Guile's foreign function interface.")
+      (license license:gpl3+))))
+
 (define-public guile-colorized
   (package
     (name "guile-colorized")